iOS devices won't connect to hotel's wifi network because it has a popup login screen

diberri

macrumors newbie
Original poster
Jun 20, 2010
1
0
I'm having trouble accessing my hotel's wifi connection from my iPad and iPhone 3GS. The process works on my MacBook Pro, and I believe it fails because the wireless access point used by my hotel requires logging in to a popup window.

My iOS devices are finding the network just fine. In Settings > Network > Wi-Fi, when I click on the network name, the "E" icon beside the "AT&T" text in the top status bar turns into the familiar wifi signal strength. Then a "Log In" overlay sweeps up from the bottom of the screen as normal. Briefly, http://www.apple.com loads and then the device is redirected to http://192.168.1.1. All of this is normal and I am used to this sort of experience when logging on to a wifi network on these devices.

The problem arises because the page at http://192.1681.1.1 is entirely blank. It's just a white page without any text or images. The overlay has an enabled back button (which takes me back to apple.com) and a blue Cancel button. Hitting the Cancel button closes the Log In overlay, removes the wifi signal strength icon, and restores the "E" icon.

On my MacBook Pro, logging in to the network first loads a blank http://192.168.1.1, but this page then opens up a a popup window at http://192.168.1.1:9988/html/ClientLoginPage.html where I supply my login credentials. I believe this is what's screwing up the iOS devices: the fancy overlay probably can't handle popup windows.

In prior (<3.0?) versions of iOS (ie, without the Log In overlay to automatically connect to a network), I believe this would've worked just fine. I would have used Settings to select the network, then would have opened Mobile Safari to load a page. This would've directed me to http://192.168.1.1, which would have prompted the popup login screen I mentioned above. And since Mobile Safari supports popups, I think this would have worked out and I could have logged in to the wifi network.

I've scoured Google and this website but can't find anyone else with these sorts of problems, but I doubt I'm alone. Any suggestions would be much appreciated.

Thanks,
Dave
 

gb21

macrumors newbie
Jan 25, 2009
21
0
same problem here with iOS 4.0 & iPhone 3GS

I'm having trouble accessing my hotel's wifi connection from my iPad and iPhone 3GS. The process works on my MacBook Pro, and I believe it fails because the wireless access point used by my hotel requires logging in to a popup window.

My iOS devices are finding the network just fine. In Settings > Network > Wi-Fi, when I click on the network name, the "E" icon beside the "AT&T" text in the top status bar turns into the familiar wifi signal strength. Then a "Log In" overlay sweeps up from the bottom of the screen as normal. Briefly, http://www.apple.com loads and then the device is redirected to http://192.168.1.1. All of this is normal and I am used to this sort of experience when logging on to a wifi network on these devices.

The problem arises because the page at http://192.1681.1.1 is entirely blank. It's just a white page without any text or images. The overlay has an enabled back button (which takes me back to apple.com) and a blue Cancel button. Hitting the Cancel button closes the Log In overlay, removes the wifi signal strength icon, and restores the "E" icon.

On my MacBook Pro, logging in to the network first loads a blank http://192.168.1.1, but this page then opens up a a popup window at http://192.168.1.1:9988/html/ClientLoginPage.html where I supply my login credentials. I believe this is what's screwing up the iOS devices: the fancy overlay probably can't handle popup windows.

In prior (<3.0?) versions of iOS (ie, without the Log In overlay to automatically connect to a network), I believe this would've worked just fine. I would have used Settings to select the network, then would have opened Mobile Safari to load a page. This would've directed me to http://192.168.1.1, which would have prompted the popup login screen I mentioned above. And since Mobile Safari supports popups, I think this would have worked out and I could have logged in to the wifi network.

I've scoured Google and this website but can't find anyone else with these sorts of problems, but I doubt I'm alone. Any suggestions would be much appreciated.

Thanks,
Dave
exact same problem here and so far haven't a solution online. Any tips??
 
Comment

RRmalvado

macrumors 6502
May 27, 2010
340
20
Have you tried disabling the Block pop-ups option in the Mobile Safari settings?
 
Comment

FluffyRAM

macrumors newbie
Feb 1, 2012
1
0
Problem still occurring, any solution yet?

My husband and I drive from GA to MI. Couple of stops, all connected OK.
Return journey and tonight we have problems.
Hotel has 3 wifi choices (pick the strongest signal!). Great! We thought...
The MacBook Pro had no problems, sign in via pop-up window.
Neither iPhone 4 would connect.
In settings they both appeared connected but 3G was still showing rather than the wifi symbol.
Each action requiring wifi would see the blank login screen appear. Repeatedly actually, becoming rather annoying.
I tried different browsers, even uploading Opera.
No good.
I searched online and found this thread!
Meh! No solution :(
I followed instructions to ensable pop-ups.
Stills Nothing.
Just the blank login screen.
Same problem, both iPhones.
Help! Anyone?!....
Thanks.
 
Comment

Maineman1

macrumors newbie
Feb 7, 2012
1
0
Move Auto-Join to OFF

I had a similar problem, and just figured out how to fix it. In my case, I returned to a hotel where I've stayed before, and had previously logged onto their free wifi. This time when I selected the hotel's hotspot under Settings, a blank login page popped up, and the page timed out without the page ever filling in or giving me a place to log in.
I struggled for awhile, and finally fixed it by going under Settings, selected Wifi, selected the hotel's hotspot, and selected the little blue arrow to the right of the hotspot name, which took me to a page with the IP address, subnet mask, etc. On that page, I found that both Auto-Join and Auto-Login were in the ON position. I moved the Auto-Login to OFF and backed out to the hotspot again. This time when I selected the hotspot, the log in page appeared, complete with the space to type my login. It now works fine.
 
Comment

electskier

macrumors newbie
Mar 5, 2012
1
0
I had a similar problem, and just figured out how to fix it. In my case, I returned to a hotel where I've stayed before, and had previously logged onto their free wifi. This time when I selected the hotel's hotspot under Settings, a blank login page popped up, and the page timed out without the page ever filling in or giving me a place to log in.
I struggled for awhile, and finally fixed it by going under Settings, selected Wifi, selected the hotel's hotspot, and selected the little blue arrow to the right of the hotspot name, which took me to a page with the IP address, subnet mask, etc. On that page, I found that both Auto-Join and Auto-Login were in the ON position. I moved the Auto-Login to OFF and backed out to the hotspot again. This time when I selected the hotspot, the log in page appeared, complete with the space to type my login. It now works fine.
This didn't work for me but then went into safari and put in my 192.168.... number got from the wifi details after following the blue arrow on the wifi page and it let me enter the login access code and says I am now registered to use the internet but still says safari can't connect to the internet
 
Comment

hoangtucolusa

macrumors newbie
May 24, 2012
1
0
Have you tried disabling the Block pop-ups option in the Mobile Safari settings?
Amazing, this work for me. I got a blank Log In Screen whenever I click to connect to the network (use a proxy with authentication name & password also). After Disabling the "Block Pop-Ups" option & also disable "Auto Log-In" when config Network. Everything back to normal. I can see the Pop-Up asking for Proxy 's UserName & Password. Just enter & everything back to normal. No Blank Log-in Screen anymore.
 
Comment

peanutismint

macrumors 6502
Apr 4, 2007
423
8
Cardiff, UK
....I finally fixed it by going under Settings, selected Wifi, selected the hotel's hotspot, and selected the little blue arrow to the right of the hotspot name, which took me to a page with the IP address, subnet mask, etc. On that page, I found that both Auto-Join and Auto-Login were in the ON position. I moved the Auto-Login to OFF and backed out to the hotspot again. This time when I selected the hotspot, the log in page appeared, complete with the space to type my login. It now works fine.
This worked for me. Simple! :) Thanks!
 
Comment

rickbrown2

macrumors newbie
Sep 30, 2014
6
0
Re: iOS devices won't connect to hotel's wifi network

I suppose, you need to get the username and password for the access.
 
Comment

Similar threads

Register on MacRumors! This sidebar will go away, and you'll see fewer ads.