iOS4 + car charger

Discussion in 'iPhone Accessories' started by anthdci, Jun 12, 2010.

  1. anthdci macrumors 6502

    Joined:
    Jun 8, 2009
    #1
    I have a griffin 12v car charger for my 3GS that i have been using since i got it last year, and it has been so helpful throughout. But i upgraded to iOS4 on tuesday, then plugged my iPhone into it today to be shown the, "this accessory cannot charge you iPhone" warning. Has anyone else had this? What has the OS got to do with whether the phone will be charged :confused:
     
  2. DonSaleen747 macrumors newbie

    Joined:
    Jun 23, 2010
    #2
    First post here, but Yes, I am having the same issue. Very frustrating
     
  3. percusso macrumors newbie

    Joined:
    Mar 22, 2008
    #3
    I've experienced a similar issue. The car charger that has worked for 12 months on my iPhone 3GS running IOS3 now refuses to work on IOS4 with the same error noted above.

    A second card charger that didn't work previously, does seem to charge my 3GS running IOS4 (there's no error message). However, it causes nasty behaviour such as rebooting my iphone, causing an unresponsive phone until the charger is unplugged, etc.

    Not happy!! Especially as I don't know how to buy a charger that is "IOS4 compatible"!

    Greg
     
  4. NightStorm macrumors 68000

    Joined:
    Jan 26, 2006
    Location:
    Whitehouse, OH
    #4
    I'm not having any problems with my Griffin Autopilot and both my 3GS and 4 running iOS4. A message comes up that says that it is not optimized for use with the device, but it charges and the AUX port works without issue. I believe there were a couple different revisions of the Autopilot; I bought mine shortly after the 3GS was released last year.
     
  5. Beauzho macrumors newbie

    Joined:
    Jun 25, 2010
    #5
    Charger problems too

    NONE of my third party charger work after "upgrade" to iOS4.

    Only Apple brand chargers are functioning.

    Hum......
     
  6. percusso macrumors newbie

    Joined:
    Mar 22, 2008
    #6
    After posting my grievances earlier, I might have found a solution to the problem. I had originally moved from IOS3 to IOS4 via the "upgrade" path. Then I had the charger issues. I have since done a full "backup and restore" of my iPhone, and volia! my car charger works again. I'd be interested to hear if this fixes the problems for others.
     

Share This Page