iOS4: Exchange calendar not working (blank)

Discussion in 'iPhone' started by MacGiver, Jun 21, 2010.

  1. MacGiver macrumors 6502a

    MacGiver

    Joined:
    Aug 12, 2007
    Location:
    France
    #1
    Since i upgraded on iOS4 my outlook exchange account is activated (as it was in the past) and show on my calendar list but no events are showing up in the calendar itself!

    Helppppp!!!
     
  2. kyleaa macrumors regular

    Joined:
    Jun 20, 2006
    #2
    Try removing and re-add the account in settings.
     
  3. MacGiver thread starter macrumors 6502a

    MacGiver

    Joined:
    Aug 12, 2007
    Location:
    France
    #3
    I did...still nothing
     
  4. scar88 macrumors member

    Joined:
    Jul 3, 2009
    Location:
    London
    #4
    ive got the same problem, it was working fine before i upgrade to the new os, anyone have any ideas?
     
  5. MacGiver thread starter macrumors 6502a

    MacGiver

    Joined:
    Aug 12, 2007
    Location:
    France
    #5
    and trying to delete the accunt and restore it made things worse...Now in addition I lost my emails...only 2 out of many are showing up!
    Apple what have you done!!!!!
     
  6. MacGiver thread starter macrumors 6502a

    MacGiver

    Joined:
    Aug 12, 2007
    Location:
    France
    #6
    OK I had to go back to settings and select al vs 3 days. I have all my mails back but still no exchange calendar items showing up while it is on the list of calendars!
     
  7. scar88 macrumors member

    Joined:
    Jul 3, 2009
    Location:
    London
    #7
    its really weird as its not working on my ipad either, not sure if its a apple problem or settings have some how changed on my works side
     
  8. MacGiver thread starter macrumors 6502a

    MacGiver

    Joined:
    Aug 12, 2007
    Location:
    France
  9. MacGiver thread starter macrumors 6502a

    MacGiver

    Joined:
    Aug 12, 2007
    Location:
    France
    #9
    I called the Apple hotline...they asked me to restore. Things have not changed. My exchange account syncs will with my mails and contacts but not the calendar (exchange calendar stil visible in the calendars list but has no content!). Again I use exchange for Outlook and it was working very well with OS3.
     
  10. MacGiver thread starter macrumors 6502a

    MacGiver

    Joined:
    Aug 12, 2007
    Location:
    France
    #10
    Me again...I called Apple and they admitted they have seen many complains about this already.
    Please post your issue on the Apple Discussion Forum so it gets a better visibility to Apple!
    http://discussions.apple.com/thread.jspa?threadID=2469473&tstart=0

    This is impacting a lot entreprise account (like mine) and Outlook OTA sync. As said before. Since OS4 my Exchange account (Outlook 2003) works fine with mail and contacts but shows a blank calendar.
    Thanks!
     
  11. MacGiver thread starter macrumors 6502a

    MacGiver

    Joined:
    Aug 12, 2007
    Location:
    France
    #11
    Those with Microsoft exchange and iPhone OS4 calendar issue? Are you on Microsoft 2003/2007/2010?
    Read this...it looks like the issue is due to iOS4 not or partially being compatible with MS 2003...
    http://discussions.apple.com/thread.jspa?messageID=11722416#11722416

    http://www.zdnet.com/blog/sybase/io...blems-with-google-apps-microsoft-exchange/212

    Thanks Steve for forgetting that so many people and companys are still running on MSE 2003
    I hope we will get a patch soon!
    X

    EDIT: Got some feedback that some are experiencing the same issue with MSE 2007 and 2010...
     
  12. kyleaa macrumors regular

    Joined:
    Jun 20, 2006
    #12
    I had issues with Exchange when I upgraded to 4.0. The ultimate solution was a restore and not restoring from backup (setting up as a new phone). All I really lost was text message history, but it was worth it in my eyes.
     
  13. MacGiver thread starter macrumors 6502a

    MacGiver

    Joined:
    Aug 12, 2007
    Location:
    France
    #13
    What kind of issues did you have? I did a restore...so my iphone was "blank" and restored with my last back up...is that what you did? I still have my SMS. Also did you loose any app history/documentation/data?
     
  14. kyleaa macrumors regular

    Joined:
    Jun 20, 2006
    #14
    That's a restore from backup. I did a restore and then told iTunes it was a new phone, ignoring the backup. My exchange calendar didn't work, and Mail would crash on launch. Attempting to remove the account in settings would crash the Settings app.

    I guess I lost some app info (like game status/scores), but all of my 'mission-critical' apps have syncing involved.

    Worst case scenario if you do a restore and don't restore from backup and the problem isnt solved, you can go back and restore from that backup afterwards & you aren't any worse off.
     
  15. MacGiver thread starter macrumors 6502a

    MacGiver

    Joined:
    Aug 12, 2007
    Location:
    France
    #15
    Thanks Kyle
    I have done a hard restore and it worked out...the bad part is that i lost my SMS...this really bugs me. I will try to find out a SW to store my SMS and restore them on a hard restored iPhone
     
  16. kyleaa macrumors regular

    Joined:
    Jun 20, 2006
    #16
    You can get them out of your backup file using Erica Sadun's mdhelper utility (found at http://ericasadun.com/ftp/Macintosh/), but it will be a sqllite file. I don't know of any way to restore these to a non-jailbroken iPhone.
     

Share This Page