iOS4 not compatable with car radio

Discussion in 'iPhone' started by dickdaney, Jun 22, 2010.

  1. dickdaney macrumors regular

    Joined:
    Dec 10, 2009
    #1
    Anyone else have this problem? I upgraded to OS4 like everyone else yesterday. When I got in the car this morning, my phone wouldn't sync with my radio. I'm using a Kenwood mp342U. The radio works fine with my nano and my wifes touch running 3.1.2. Damn you apple!
     
  2. datamage macrumors member

    Joined:
    Oct 11, 2006
    #2
    I recall reading about this somewhere, and the trick was to load the iPod app before you connect the phone with your car. See if that does anything. Good luck.
     
  3. Chupa Chupa macrumors G5

    Chupa Chupa

    Joined:
    Jul 16, 2002
    #3
    I've been using the GM Cand. since it was released and have no probs w/ the BT connecting w/ my car, which is 3 years old -- in fact bought it a couple months before the iPhone came out.
     
  4. dickdaney thread starter macrumors regular

    Joined:
    Dec 10, 2009
    #4
    this is the message I get now.
    [​IMG]

    before I would get the whole "this device is not compatible with iphone blah blah blah. would you like to put your phone in airplane mode." Now nothing happens. :mad: Now it back to the old trusty axillary cable. I'll have to deal with two plugs. the sync cable to charge the phone, and the aux cable to listen to music.
     
  5. dan925 macrumors newbie

    Joined:
    Jun 22, 2010
    #5
    This sucks

    Yea, my 3gs w/3.1.3 worked just fine with my 2010 Honda Fit, now with 4.0
    It doesn't work, I have tried playing song first then plugging it in. Also no go..

    Any idea why apple screwed this one up....
     
  6. Etnies419 macrumors 6502

    Joined:
    Sep 9, 2008
    #6
    I'm scared... I have the same radio, but haven't updated my 3G. I'm getting an iPhone 4, so I haven't updated it. I hope my iPhone 4 will work with the radio, since I use the iPod connection all the time. I really don't want to use the AUX input either.
     
  7. Krevnik macrumors 68040

    Krevnik

    Joined:
    Sep 8, 2003
    #7
    I feel like I've dodged a bullet I think.

    I've got the same 342U head unit, with a bluetooth adapter I added about a year after I had the head unit installed. I stopped using the USB connection because of charging issues (the iPhone can draw more than 500mA when running a GPS app with the screen on, and the USB port only provides 500mA).

    I've noticed that the USB control with the head unit was getting fairly flaky with the last couple iPhone OS updates prior to 4.0 though.
     
  8. AlanShutko macrumors 6502a

    Joined:
    Jun 2, 2008
    #8
    I have a Kenwood KDC-X692 and iOS 4 does work with it.

    I'll admit, it was very touchy on my 3g when I upgraded and restored my backup. I was also having a lot of lag issues. I suspect the process didn't start in time to connect to the head unit.

    I've since restored the 3g as a new phone and synced my music over to it and it now works pretty well. It occasionally needs a couple tries to sync, but it needed that with 3.1 as well.
     
  9. Krevnik macrumors 68040

    Krevnik

    Joined:
    Sep 8, 2003
    #9
    Could be related to the firmware on the head unit in that case, the X692 is newer than the 342U
     
  10. jshbckr macrumors 6502

    Joined:
    Apr 20, 2007
    Location:
    Minneapolis, MN
    #10
    I know this message pops up, but have you tried to continue using it? Going into the iPod, etc?

    Because this same thing happens on mine (used to give the airplane mode message) and it still works perfectly fine with this new dialog box.
     
  11. IamFaustus macrumors member

    Joined:
    Oct 13, 2009
    #11
    Try restarting your phone after connecting it to the stereo. I have the Alpine iDA-X305. When I first plugged the phone in the head unit it wouldn't play. I could search through the music on the phone but it wouldn't play.

    I was a bit worried that my 3 month old stereo was not compatible. After restarting the phone everything worked. I had read online that restarting the phone may solve the problem. I had already restarted the phone after the iOS4 install, so I didn't think it would help, but it did.
    Best of luck!
     
  12. California King macrumors 65816

    Joined:
    Sep 20, 2007
    #12
    Hmm, I have the Kenwood KDC-MP345U and it works fine with my 3GS running JB'd/Unlocked iOS 4.0...no idea if it will work with my iPhone 4 though (fingers crossed!)

    Does it display "iPod error" on the stereo?
     
  13. IamFaustus macrumors member

    Joined:
    Oct 13, 2009
    #13
    Mine didn't, but it did have the accessory is not optimized... message.
     
  14. ReallyBigFeet macrumors 68030

    ReallyBigFeet

    Joined:
    Apr 15, 2010
    #14
    iOS4 on my 3G works fine on both my Peripheral iPod2Car adapter for my Chevy as well as on the factory Navi headunit for our 2010 Mazda CX9. Bluetooth stereo streaming also works on the latter as well. On the CX9, the iPhone goes into Dock mode, whereas on the Peripheral device, it's just sending sound out via the connector while the iPhone remains 'live.'

    So that's all three methods x 2 different iPod/auto integrations. All working for me.
     
  15. rans0m00 macrumors 6502

    Joined:
    Jun 21, 2010
    #15
    Have a kdc-x493 and it mostly quit working with my ipod touch3g after I forgot what update but about 6 months ago. I had to switch it to where my ipod still controls everything for it to work. Called kenwood more times than I can count to complain and try to figure out a solution and the final verdict was... There is no good way to update this head unit everytime apple comes out with an update... Which makes sense but not any less frustrating.
     
  16. bpfesq macrumors regular

    Joined:
    Feb 26, 2010
    Location:
    Omnipresent
    #16
  17. cdlenfert, Feb 8, 2011
    Last edited: Feb 8, 2011

    cdlenfert macrumors newbie

    Joined:
    Feb 8, 2011
    #17
    Hey California King, I have the same Kenwood unit and an iPhone 4. I'm looking to integrate it so I can charge and play through the stereo at the same time. Do you use the kenwood cable with the aux and USB connection? If so does the unit lock the phone and force you to control playback through the stereo's controls? I used to have a 5th gen and when I hooked up to the USB it would scan all of my songs like a massive USB drive and play them randomly. Track navigation was pretty much impossible. I just wanted to know how your setup works before I rig my own.

    Actually in looking closer my stereo is MP435U. I guess this doesn't apply.
     

Share This Page