iOS5 charging problems?

Discussion in 'iPhone' started by Gjwilly, Jun 9, 2011.

  1. Gjwilly macrumors 68030

    Joined:
    May 1, 2011
    Location:
    SF Bay Area
    #1
    I'm using iOS5 on a 3GS and I keep getting the "Charging is not supported with this accessory" message.
    Thing is that I'm using the official iPhone power block.
    Anybody else?
     
  2. bmms8 macrumors 68020

    Joined:
    Dec 19, 2007
    #2
    try a hard reset, hold home and power button until you see apple logo.
     
  3. unixunderground macrumors member

    Joined:
    Feb 2, 2011
    #3
    same happening here, iPod touch 3gen with original charger too...
    And the strange thing, is that if I unplug and then replug it a few times, it starts charging, and then stops again after a few minutes....
    And I tried to reboot and restore iOS but nothing.....
    Does anyone have a solution on this?
     
  4. unixunderground macrumors member

    Joined:
    Feb 2, 2011
    #4
    I found out what the problem was..
    I was actually using the iPad charger as I got used to carry that one only..
    And as the ipad charger haves a stronger voltage/output , the ipod recognized it as an unofficial accessory....
    Must be some kind of bug.. hope apple get it fixed with the next update tough , as having to carry two chargers , would be much more than just annoying .....
     
  5. Gjwilly thread starter macrumors 68030

    Joined:
    May 1, 2011
    Location:
    SF Bay Area
    #5
    Well mine is not the wrong charger.
    If I do a hard reset while the phone is plugged in the phone will reboot and then start charging normally.
    But after I unplug and replug the problem returns.
    No problems with USB charging.
     
  6. findbenjamin, Jun 20, 2011
    Last edited: Jun 20, 2011

    findbenjamin macrumors newbie

    Joined:
    Jun 20, 2011
    #6
    Add me to the list of affected folks.. 3gs. works fine for days, now it won't work and I'm at 4% battery.

    FARK!

    Problems with:
    charging from 2010 MacBook Pro (Late 2010 model)
    charging with car adapter (AT&T branded, sold as a bundle with iPhone)
    charging with iPad brick
     
  7. findbenjamin macrumors newbie

    Joined:
    Jun 20, 2011
    #7
    Bugger...
    I used an Apple iPad cable (rather than my "made for iPhone" certified one) and it works. So... apparently "Made for iPhone" isn't.

     
  8. lins macrumors newbie

    Joined:
    Jun 21, 2011
    #8
  9. Gjwilly thread starter macrumors 68030

    Joined:
    May 1, 2011
    Location:
    SF Bay Area
    #9
    I found I can avoid the problem if I never let the battery fall below around 35%.
    In other words, the problem only shows up when the battery is lower than 30-35%.
    Lower than that and I have to use the hard-reset trick or else charge from USB.
     
  10. ekrueger24 macrumors regular

    Joined:
    Oct 12, 2011
    Location:
    London, UK
    #10
    I am just now having the same problem. I just installed iOS 5 on my iPhone 4 and yesterday on the previous version of iOS it charged just fine from my MacBook Pro (mid-2009 version) with the original cord that came with the phone. Suddenly today after fully upgrading to iOS 5 it stopped charging and stated "Charging is not supported with this accessory" or something to that effect.

    To make sure it wasn't my USB port I plugged in a thumb drive and it read the drive normally and to test the cable I plugged my iPad 2 into it (also running iOS 5) and it charges normally as well.

    I tried plugging the iPhone into a wall charger and still comes up with the same message, even after I tried the cable that came with my iPad 2.

    I tried the trick about plugging it in and doing a hard reset, which worked to a small extent, it now just displays the fully charged icon, but the phone is at 63% battery and appears to still be losing power.

    Anyone have any suggestions about how to possibly fix this issue?

    Thanks!
     
  11. djooker macrumors newbie

    Joined:
    May 24, 2010
    #11
    Having same problem here, iphone 3gs upgraded to ios 5.
    First it was only the tomtom gps car kit that threw the charging is not supported with this accessory. Today it's the wall charger that said that.
    Warranty is over, but hey this is something they must sort out asap.
    Will try to contact apple if they have any clever ideas.
    May i suggest you guys dont update iphone 3gs to ios5 :)
    Sorry, your phone is just too old;)
     
  12. Thetonyk123 macrumors 68000

    Thetonyk123

    Joined:
    Aug 14, 2011
    Location:
    Earth
    #12
    I got that in iOS 4 with my cheapo $2 charger and it turned out it was the official apple cable. I bought a new cable and it works ever since.
     
  13. jtsee2 macrumors newbie

    Joined:
    Oct 24, 2011
    #13
    Charging is now working.

    Background:
    • iPhone 3GS

    • Charged flawlessly with "non-Apple" Apple certified USB Cable
    ********​
    • Upgraded to iOS 5

    • "This accessory is not compatible..."
    Old Setup:
    I plugged my USB Cable into a USB hub that plugged directly into my USB port (It does not plug into the wall to get power). I never had a problem using this one for 2 years.

    New Setup:
    So, I had another USB hub that does plug into the wall for it's power and voilà it worked like a charm! (Here's the one that I have - Search Amazon: "B003YSYDBC")

    I hope this is a solution that works for everyone.
     

Share This Page