iOS5 - Completely ruined my calendars! :( - Duplicates etc

Discussion in 'iOS 5 and earlier' started by aircanman, Oct 12, 2011.

  1. aircanman macrumors 6502

    Joined:
    Feb 2, 2011
    Location:
    UK
    #1
    Well, I may be doing something wrong but after updating and activating the cloud, now I am getting loads of duplicate calendar entries. And for some reason, they are sticking on the cloud website but not on the phone or iCal.

    I have actually deleted all my calendars on the computer and am using the cloud on (is this right?)

    So I currently dont have a calendar on iCal just the cloud one. It still is not working right.

    Gutted!
     
  2. Deamos macrumors member

    Joined:
    Mar 25, 2009
    #2
    Strange. Perhaps you should go to icloud.com and see what it says there.
     
  3. sprocket003 macrumors newbie

    Joined:
    Jun 25, 2007
    #3
    Duplicates

    I had the same problem but the duplicates were on my iPhone but icloud.com and iCal showed everything correctly. In iCloud under Settings on iPhone I turned calendars off (deleted those on my iPhone) and then turned it on again so it resynced the calendars from the iCloud and it worked.
     
  4. Learjet035 macrumors 6502

    Joined:
    Feb 24, 2005
    Location:
    S. Floriduh
    #4
    I had a similar issue.
    Try plugging into iTunes and unchecking everything that is duped
    ie: contacts/ calendars
    Then just let the cloud do it's thing.

    I think that's what's up
     
  5. daramos macrumors newbie

    Joined:
    Sep 3, 2010
    Location:
    Blacksburg, VA - Managua, Nicaragua
    #5
    Having similar issue..any advice pleasseeee

    I had my calendar duplicate on my mac and on iphone..
    on my mac I just deleted all my on my mac calendars and left
    the ones that are on the icloud. That got my mac ical working well with
    no duplicates..on my icloud also I have no duplicates but on my iphone
    even after turning the icloud calendar on and off which then lets you delete the calendars on the iphone I still get my calendar in the notification center with the things I have to do and if I click on the ical app I have nothing. If I go back and turn the icloud calendar sync on which should replace everything then I get duplicates of each event on the notification center and my calendar appears normally without duplicates in the ical app. :apple:
     
  6. ugp macrumors 65816

    ugp

    Joined:
    Jan 7, 2008
    Location:
    Inverness, Florida
    #6
    iCloud did this to me on my iMac. It duplicated my Google account for some reason as soon as I enabled iCloud to move everything over. It was nothing to fix though. It actually had the account on there twice so I just removed one.
     
  7. Joe-Diver macrumors 6502

    Joe-Diver

    Joined:
    Aug 2, 2009
    #7
    I just finished updating my iCal...

    When I clicked on the Calendars button, all were selected...meaning, all the "On My Mac" cals and "iCloud" cals...so I deselected the "On MY Mac" cals and only have the iCloud ones checked.

    Got rid of all the duplicates and now my iCal is identical between my iMac, MBP and iPhone....updates are almost instant.
     
  8. PaperQueen macrumors 6502

    PaperQueen

    Joined:
    Aug 16, 2007
    Location:
    Just this side of insanity (Minneapolis)
    #8
    Ditto here. Your solution worked like a charm--thanks!

    Same here--have been using "On My Mac" for iCal since MobileMe KILLED them in March (was in the midst of a two week speaking tour out of state--great time to lose your calendar). Once I turned off the laptop copies, all worked well.
     
  9. b17777 macrumors member

    Joined:
    Jul 14, 2008
    Location:
    St.Paul MN
    #9
    I have duplicates on my phone but not my iMac.
    I installed Lion on my iMac the other day,activated my phone today but I have not set up iCloud yet. I have had .mac for years tho. On my phone calendars, the duplicates seem to be that I have both .Mac and .Me calendars now. I want to set up iCloud but I don't want my duplicates to follow on to my iMac and also my MacBook which is still running 10.6. that I can't upgrade to Lion yet.
    What's the best way to go about this now ?
     
  10. b17777 macrumors member

    Joined:
    Jul 14, 2008
    Location:
    St.Paul MN
    #10
    Ok, I think I figured it out.
    In iTunes I
    Checked "Sync iCal Calendars"
    Checked "Selected Calenders " But did not select ANY calenders
    Under Advanced
    Checked "Replaced information on this phone Calendars"
    Synced
    Unchecked "Sync iCal Calendars"
    When it asked to remove or delete calendars say yes
    Sync
    And now everything is working as it should.:)
     

Share This Page