iOS5 losing WiFi again

Discussion in 'iOS 5 and earlier' started by SurferMan, Nov 8, 2011.

  1. SurferMan macrumors 65816

    Joined:
    May 14, 2010
    Location:
    South FL
    #1
    So a few weeks ago had no WiFi on our 3GS and 4 for days (it worked fine right before after the update). So after restoring numerous times, finally worked again. Lo and behold, today, just like before... no WiFi unless I'm within like 5 feet of the router. I'm in my home office on the other side, and it keeps going from 3G to 1 bar of WiFi sometimes.

    I know it's not the router, impossible, I have a good N router and my Macbook Pro picks up the signal all the way on my dock behind the house. All other devices work fine, and our iPhones worked fine before on the network. But even then, I've reset and changed parameters in the router, no difference. Only after the iOS 5 update does this keep happening.

    Nobody else on here has this problem? This seems to be the only Mac forum with like no post about it. Elsewhere online you can find tons and tons of post on this. Like from Apples Discussions: https://discussions.apple.com/thread/3381610?start=0&tstart=0

    Why it's only affecting some and not others, and why some things (Resetting etc) fix it and not others... no idea, but it's irritating as hell. My local Apple store said they've had people come in with their phones after updating saying their having WiFi issues, but they don't show anything in their system from Apple nor online does it look like Apple is even addressing this issue.
     
  2. madsci954 macrumors 68030

    Joined:
    Oct 14, 2011
    Location:
    Ohio
    #2
    My wife has been having similar issues with here 4S, only hers it comes and goes and very spotty. We live in a studio, so we are no more than 10 feet away from our router at any given time (minus leaving the house of course.)

    I haven't had any issues with my 4 though, but I have Cellular Data on and I think hers is turned off. I'm going to turn mine off and see if mine randomly drops or not.
     
  3. SurferMan, Nov 8, 2011
    Last edited: Nov 8, 2011

    SurferMan thread starter macrumors 65816

    Joined:
    May 14, 2010
    Location:
    South FL
    #3
    It has to be something in iOS 5 software that's causing this bugging out. Looks like people have even gone to Apple stores and showed that thread I posted above and others to the workers there after they came in with WiFi issues.

    Mine was just holding on to 1 bar (when I used to get full bars in my home office), and if I start walking to the living room it goes back to full bars. Don't know why some aren't affected by this and have no problems, and others are.
     
  4. Calidude macrumors 68000

    Calidude

    Joined:
    Jun 22, 2010
    #4
    I've had this issue with my 3GS since iOS 5 but it only happened once. You have to toggle Airplane mode. Hasn't happened since.
     
  5. SurferMan thread starter macrumors 65816

    Joined:
    May 14, 2010
    Location:
    South FL
    #5
    Believe me I tried that lol... did nothing on either phone.Reset network again and did another restore (I've now restored like 15 times since iOS 5). No change, they only work in the living room area for WiFi, you start walking away and the bars drop until either there's no WiFi or barely holds 1 bar. Before iOS 5 I had full bars across the house, and could even keep 2 bars at my pool.

    Apple screwed something up in iOS 5 causing this issue as there are way to many complaints now elsewhere online. But what fixed it for one person, doesn't seem to work for another and vice versa. What's worst is Apple won't even acknowledge it, I even went to our genius bar at the mall when I was there. They told me they've had quite a few people complaining about this after updating to iOS 5, however Apple shows nothing in their system as far as a fix or any acknowledgement of the issue. My phone connected to their store WiFi, then to show them, as I started walking around the store and towards entrance the signal would drop. I said it worked perfectly before, they only started this after updating :rolleyes:
     
  6. cmeisenzahl macrumors 6502

    Joined:
    Oct 7, 2005
    #6
    It's definitely freaky that this seems to be largely a 3GS problem.
     
  7. SurferMan thread starter macrumors 65816

    Joined:
    May 14, 2010
    Location:
    South FL
    #7
    Happens to our 4 as well.

    Searching around it seems the Apple stores have had people come in with the 4S as well either having no or intermittent WiFi, and they got a replacement. So obviously Apple is having a QC issue on the 4S for that similar issue.... but on the 3GS and 4 it has to be a software issue as these are phones that worked perfect before the update.

    I mean our local genius bar said they've had people call or come in regarding WiFi trouble after going to iOS 5 but there's nothing they can do b/c Apple won't acknowledge it, nothing as far as a fix in their system.

    I have unlimited, but this could screw a lot of people as they'll be stuck on 3G using up their data plans way faster then before.

    Look at some of the recent post regarding this:
    I'm really surprised this issue hasn't been reported on by Gizmodo or any other big tech site (that I've noticed). I really thought this issue was just something to do with my wireless router or something but I have tried to reset it a few times. My 3GS connects and even shows the wifi signal icon but it actually works only for a few seconds and just doesn't for no reason (and the wifi icon is still showing a signal after it stops working). I'm not going to even bother restoring my phone because I'm almost possitive it won't solve the issue considering it looks like most of the people that replied to this post tried that and it failed to solve the problem. I really hope 5.01 takes care of this issue.

    It's good to see I'm not the only one with the iOS5 WiFi problem. However, I cannot even get it to work on public WiFi hotspots and I can't control the settings on those devices. When is Apple going to man-up and fix this egregious problem?
     
  8. Calidude macrumors 68000

    Calidude

    Joined:
    Jun 22, 2010
    #8
    I think its pretty obvious that iOS devices prefer Airport routers over other routers and that's why the Wifi issue never really goes away every year. It's not a software issue. It's a hardware issue. Apple needs to spend a couple extra bucks and use a chipset that isn't beholden to their routers and this problem will go away completely.

    Also, I will say that some people who complain about Wifi issues are really ignorant people who buy crappy routers and never update their firmware, so there's that problem as well.
     
  9. Thetonyk123 macrumors 68000

    Thetonyk123

    Joined:
    Aug 14, 2011
    Location:
    Earth
    #9
    This isn't the same for me but when I cover the top of my ipod touch, it loses wifi signal. This was not there in iOS 4. Really annoying if i'm playing a online shooter in my bed (which is far from my router) and it cuts off the signal.
     
  10. Menel macrumors 603

    Menel

    Joined:
    Aug 4, 2011
    Location:
    ATL
    #10
    Been having this problem, but it is not necessarily iOS 5 related. Note I've been running it since b2, so it's seen a lot of use on various networks.

    Office G network, solid and reliable.
    Every hotspot I've used, solid and reliable.
    Tethered WIFI to iPhone, solid and reliable.
    iPad to Linksys E2000 DDWRT N-2.4GHz router, solid and reliable.

    Changed home network around, new modem/router from ISP has G2.4 built in, so switched E2000 to N-5GHz. Now get frequent connection drops with iPad.

    5 GHz quirky in router? 5 GHz quirky in iPad? Hmmmm other experience out there?
     
  11. SurferMan, Nov 10, 2011
    Last edited: Nov 10, 2011

    SurferMan thread starter macrumors 65816

    Joined:
    May 14, 2010
    Location:
    South FL
  12. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #12
    On iOS 5 my iPhone 4 when used as a WiFi hotspot often won't show up. A reboot will usually fix this. A minor niggle I suspect will get fixed in the next update or two.
     
  13. SurferMan thread starter macrumors 65816

    Joined:
    May 14, 2010
    Location:
    South FL
    #13
    True, and I'm not a fan of the airport router at all. Never been a fan of Apples WiFi system. I used to have a ton of problems with my Macbook Pro connecting and dropping WiFi, or going slow as hell when the PC's on the same network were blazing. It still does that once in awhile.

    I noticed also that Mac's prefer N routers, I bought a dlink 655 xtreme last year.

    This is so f'n irritating though. One of my friends that didn't do the update before, did now and knew my issue. Said his works at home still but it's been screwy, only showing 2 bars max and says it drops the signal a lot. Then when he was at Starbucks it wouldn't connect to their network even though it showed up on the phone with full bars.

    I'm in my home office right now, and usually with iOS 5 I can get at least 1-2 bars if it doesn't drop the sig, but it's not even showing up in my network today. Yet I walk towards the living room and it pops up.
     
  14. Leslie Barbaro macrumors newbie

    Joined:
    Nov 12, 2011
    #14
    I have issues with my 3gs even with airports. It only started after upgrading the iOS. Same problem as others seem to be reporting. I need to be within 3 feet of the router to get 4 bars. When I move even 10 ft. away (where I previosly had no issues picking up wifi) I have no connection at all.

    This is super frustrating. I can't believe more people aren't outraged about this, especially those who have limited data plans. It's clearly a software issue. Apple has to address this, right?
     
  15. SurferMan, Nov 14, 2011
    Last edited: Nov 14, 2011

    SurferMan thread starter macrumors 65816

    Joined:
    May 14, 2010
    Location:
    South FL
    #15
    My 3GS is jailbroken so I downgraded back and WiFi works perfect as it did before. Re-installed iOS 5 (not 5.0.1) and still can't get WiFi unless I'm near the router so there's proof right there Apple screwed up the software.

    My 4 has the same issue but it's not jailbroken so I can't downgrade back
     
  16. Leslie Barbaro macrumors newbie

    Joined:
    Nov 12, 2011
  17. palmerized macrumors regular

    Joined:
    Nov 15, 2007
    Location:
    Toronto, ON, Canada
    #17
    I have two iPad 1's and they both suffer from wifi drop off or can't connect. I'm running 5.0.1 on both. Wifi works fine on my iMac.

    I even tried plugging in an Airport Extreme and still have problems.

    Seems like the range is way down. If I'm closer to the router it gets better.

    Hope a fix is on the way.
     
  18. austinguy23 macrumors 6502a

    Joined:
    Oct 8, 2008
    #18
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

    My iPad has always had shoddy wifi even with the airport extreme and latest iOS 5.0.1. My iPhone 4S sometimes drops full wifi connectivity and then reconnects seconds later. Weird.
     
  19. Ashwood11 macrumors 65816

    Joined:
    Nov 10, 2010
    Location:
    US
    #19
    I have the original iPad and an old Airport Extreme on iOS 5.0.1 and I don't have any WiFi issues. My Airport Extreme is located in the center of the house and I get max signal in all rooms.
     
  20. BillyBobBongo macrumors 68020

    BillyBobBongo

    Joined:
    Jun 21, 2007
    Location:
    On The Interweb Thingy!
    #20
    This is being looked at by Apple, you of course can help to by sending console logs showing the WiFi dropping out to Apple via the bug reporter. http://bugreport.apple.com/

     
  21. rdprice737 macrumors newbie

    Joined:
    Dec 3, 2012
    #21
    Go to Settings>iCloud>Storage & Backup> and turn off iCloud Backup
     

Share This Page