iOS5 - stop SPAM mail notifications?

Discussion in 'iOS 5 and earlier' started by elitypes, Oct 17, 2011.

  1. elitypes macrumors newbie

    Joined:
    Oct 5, 2007
    #1
    Hi all,

    I tried searching this topic in the forums but had no luck. My question is if there is a way to only receive mail notifications for certain mailboxes, more specifically just my inbox. With the new iOS I receive notifications on my lock screen and in the notification for all my emails including SPAM. This is a huge pain and quite frankly it can be annoying/embarassing. I will check my phone and see notifications on the lock screen for all the SPAM I have received, emails from bogus websites, for bogus offers etc.

    After checking online and exploring all the settings I can't seem to figure out if this is possible. I'd rather see notifications for actual emails from friends, work etc. without seeing all these SPAM mail notifications.

    Any advice would be much appreciated. Thanks in advance guys.
     
  2. mms13 macrumors 6502

    Joined:
    Jun 29, 2010
    Location:
    Baltimore, MD
    #2
    Use gmail or anything else with a decent spam filter.
     
  3. Menel macrumors 603

    Menel

    Joined:
    Aug 4, 2011
    Location:
    ATL
    #3
    Sign up for gmail, sync using their exchange method with server m.google.com.

    Exceptional, if sometimes too strong, spam filtering.

    Plus, any filter you setup to label/categorize email and tell it to skip the inbox, then you don't get pushes for those either.
     
  4. mreddys10 macrumors regular

    Joined:
    Jul 29, 2008
    #4
    Setting up gmail as a Microsoft exchange account will let you select exactly what folder you want to sync to your phone. This is not possible if you used the default gmail settings. Added benefit: your mail gets pushed to your phone
     
  5. Ashwood11 macrumors 65816

    Joined:
    Nov 10, 2010
    Location:
    US
    #5
    Spam filter on Yahoo Mail also solves this problem.
     
  6. daftpunkstu macrumors member

    Joined:
    Oct 17, 2011
    Location:
    Edinburgh
    #6
    never had a problem with google running on exchange :)
     
  7. elitypes thread starter macrumors newbie

    Joined:
    Oct 5, 2007
    #7
    Thanks guys. I actually already had my gmail set up as an exchange server to allow for true push email. That wasn't the issue. After checking through the settings I think my issue was that I had the exchange server set to push both my inbox and my spam. Not sure how that happened but I set it only to sync my inbox. I am hoping that solves the issue.

    Thanks again!
     
  8. Ashwood11 macrumors 65816

    Joined:
    Nov 10, 2010
    Location:
    US
  9. shanahan macrumors newbie

    Joined:
    May 5, 2016
    #9
    --- Post Merged, May 5, 2016 ---
    I have spam filter on my Yahoo, but my iphone keeps pushing spam notifications. It started about a month ago and I couldn't find anything in Settings to stop it. I only want notifications for my Inbox.

    Any ideas?
     
  10. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #10
    What iOS version is this on? Using Apple's Mail app on the iPhone/iPad?
     
  11. shanahan macrumors newbie

    Joined:
    May 5, 2016
  12. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #12
    It sounds like this thread is more about Apple's Mail app on iOS 5 (or earlier), so it's hard to say how much would really apply to something outside of that. So what app are we talking about?
     
  13. shanahan macrumors newbie

    Joined:
    May 5, 2016
    #13
    I use Yahoo for email. Until recently, spam emails went straight to my spam folder without notification. Now, I am getting notifications pushed of every spam mail that comes in. I don't want that and don't know how to stop it, as I still want regular email notifications to push.
     
  14. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #14
    I understand that Yahoo! is the email service provider, so are we talking about the Yahoo! Mail app that is being used and sending these notifications?
     
  15. shanahan macrumors newbie

    Joined:
    May 5, 2016
    #15
    I don't have a separate Yahoo App. I added Yahoo as an email account in settings.
     
  16. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #16
    So that means you are using the built-in Apple iOS Mail app (even though earlier you weren't using it)?
     
  17. shanahan macrumors newbie

    Joined:
    May 5, 2016
    #17
    My bad. I am using Apple's mail app. Sorry for the confusion...
     
  18. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #18
    It's strange that it would notify you of anything other than Inbox as that app isn't really set to notify of anything outside of what comes into the Inbox. Does this happen for all Spam emails? And you are certain they are in the Spam folder?
     
  19. shanahan macrumors newbie

    Joined:
    May 5, 2016
    #19
    yes, absolutely certain
    and it is strange as it started maybe a month ago
     
  20. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #20
    Odd. Perhaps it might be worth a try deleting the email account on the phone and setting it up again to see if reconnecting it all might resolve it? Also might be worth trying to get into Yahoo! Mail using a web browser on a computer and checking settings there, especially related to Spam, in case something might have changed for some reason or anything like that.
     
  21. shanahan macrumors newbie

    Joined:
    May 5, 2016
    #21
    Checked settings via my computer, but there was nothing related to stopping spam notifications.

    i thought about deleting account and re-adding. I am always afraid I will lose my emails, contacts, etc. Maybe I will give it a shot.

    Thank you for your time.
     

Share This Page