iOS5 switches from Dock Connector to BT

Discussion in 'iOS 5 and earlier' started by Microradian, Oct 14, 2011.

  1. Microradian macrumors newbie

    Joined:
    Oct 14, 2011
    #1
    Hey everybody, I updated my iPhone 3GS to iOS5 yesterday. Ever since then I've had a problem where the audio output will automatically and randomly switch from the dock connector to the bluetooth audio output. If I go to the iPod app (now called "Music") and switch the audio back to "dock connector" it will play through the dock connector audio for a minute or two and then it bounces back to bluetooth unexpectedly. I really don't want to use bluetooth audio streaming as I loose the iPod like functionality that's built in to the cars stereo system.

    I've had it set up and working in my car on iOS4 without any issue. I would play the audio through the dock connector and have the bluetooth setup to handle the handsfree phone calls.

    I have a 2012 Volvo S60

    Anybody else have this issue?

    Thanks
     
  2. BVDS macrumors newbie

    Joined:
    Oct 16, 2011
    #2
    I have the same problem, even without BT switched on

    I'm driving an iPhone 3GS and a Volvo V60 model 2011 and experienced the same problem repeatedly.
    Today I left Bluetooth switched off and even then lost sound on 1 occasion. Un- and replugging the dock connector did not help and the iPhone wouldn't let me switch back to dock connector neither.
     
  3. zobby macrumors newbie

    Joined:
    Jul 5, 2011
    #3
    If it helps, I have a 2011 Fiesta with Bluetooth and dock connector. Mine does the same, I think the car is sending a signal to the iPhone to start playing through bluetooth automatically. It Might be worth speaking to Volvo (as I am going to do with Ford) to see if they have a firmware update for the cars stereo that will stop this behaviour.

    As far as I can see theres no way to stop it on mine unless I turn bluetooth off completely at the moment.

    As I say - probably doesn't help but it might make you feel a little better? :)
     
  4. bwaadass macrumors newbie

    Joined:
    Mar 4, 2004
    Location:
    UK
    #4
    Yep I have the same problem, iPhone 4s iOS5. Car is Range Rover Evoque.

    Even after I manually select the "Dock Connecter" it defaults back to the Bluetooth connection approx every 40seconds or so. After two or three rounds of this it then locks to bluetooth and the iphone ipod menu doesn't work to even give me the option to change.

    Very frustrating, and bascially means I have to keep the bluetooth switched off if I want to listen to music from my phone. (Streaming via bluetooth sounds worse and does not give the full artist browsing functionality).
     
  5. AustinIllini macrumors demi-god

    AustinIllini

    Joined:
    Oct 20, 2011
    Location:
    Austin, USA
    #5
    Maybe this is related, but when I plug in my iPhone into my 2008 Audi A4, music stops playing and no matter what I do, I can't get it to play again when I remove my iPhone. :confused:
     

Share This Page