iPhone iOS6.0.1 / iP4 / Can't switch WIFI on!

Discussion in 'iOS 6' started by MyRomeo, Nov 24, 2012.

  1. MyRomeo macrumors 6502

    MyRomeo

    Joined:
    Jul 22, 2010
    Location:
    United Kingdom
    #1
    HELP!

    My sister has an iPhone 4 that has been great for over 2 years now. She updated to iOS6 when it was released with no problems at all. She then updated to 6.0.1 and now can not turn wifi on. That is, the wifi toggle switch does not respond, it is always 'off'.

    We have tried (well, I have suggested, she has tried!) the following:

    reset network settings - nope
    reset all settings - nope
    erase all content and reset all settings - nope
    restore and set up from backup (itunes) - nope
    restore and set up as new device - nope

    At this point I am stuck. What could have caused this? (I suspect 6.0.1!) and how can she fix it? I have suggested she waits a few weeks hoping for 6.0.2 update and maybe that will fix it but if that is a long way from release or doesn't fix it, or maybe there is something she can do to fix it then that would be better.

    Can anyone help please? :(
     
  2. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #2
    Restore the phone to clean 6.0.1
    Test the Wifi, if it works, restore her content.
     
  3. Tobias Funke macrumors 6502a

    Tobias Funke

    Joined:
    Apr 3, 2012
    #3
    I dont know if this helps but I have found none of the slider buttons work on ios 6!!

    You have to slide the slider not the button!!

    I hope they fix this problem because ios 5 slider buttons work perfectly!!
     
  4. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #4
    You have a faulty install, just restore (re-install the 6.0.1 firmware)
     
  5. MyRomeo thread starter macrumors 6502

    MyRomeo

    Joined:
    Jul 22, 2010
    Location:
    United Kingdom
    #5
    Thanks for the replies.

    Have tried a clean restore and clean install in iTunes and it still doesnt work. Could it be the ios file that my sis has saved is itself the fault? If she deleted the file and hit restore would it force iTunes to download a fresh copy from apple and reinstall that?
     
  6. MyRomeo thread starter macrumors 6502

    MyRomeo

    Joined:
    Jul 22, 2010
    Location:
    United Kingdom
    #6
    Update

    Sis deleted the ipsw file and did a clean restore as a new phone. Nothing. Still no wifi. She is going up see apple and expects to face the out of warranty replacement cost.
     
  7. iAll macrumors member

    Joined:
    Oct 24, 2012
    Location:
    SE NH
    #7
    Did she try to shut off the phone and then a (hard) reboot?
     
  8. OriginalClone macrumors regular

    OriginalClone

    Joined:
    Jul 14, 2012
    #8
    This happened to me after I dropped the iPhone 4 I had a while back. A restore wouldn't work and I had it replaced in warranty. She may have messed up something internally is my best guess.
     
  9. MyRomeo thread starter macrumors 6502

    MyRomeo

    Joined:
    Jul 22, 2010
    Location:
    United Kingdom
    #9
    Thanks guys.

    Yeah she has tried the hard reboot route too. I'm guessing she has dropped it or spilled liquid on it or something and its somehow only affected the wifi. Anyhow she is visiting me next weekend and our local apple store is only a few miles from here so I'm sure she will get it sorted then.
     

Share This Page