ios6 will require Mountain Lion for development?

Discussion in 'iOS Programming' started by tranceFusion, Jul 25, 2012.

  1. tranceFusion macrumors member

    Joined:
    Aug 4, 2010
    #1
    I'm sorry if this is completely obvious. I just acquired a 2008 white macbook with the hopes of goofing around with some iPhone/iPad development. This machine is not on the supported list for mountain lion.

    When ios6 is released everyone with current gen iphones and iPads will upgrade correct? And at that point I will need to do dev work on xcode 4.5 which only runs on mountain lion, correct? Will this 2008 macbook be completely worthless for development at that point? Or will I still be able to develop apps targeting the current iOS API? (Cause I'm assuming everyone doesn't recompile their apps the moment a new iOS version comes out, and they still run.)

    Any insight on how this works is much appreciated. Thanks!
     
  2. ArtOfWarfare macrumors G3

    ArtOfWarfare

    Joined:
    Nov 26, 2007
    #2
    When iOS 6 is released, Apple will stop accepting apps targeting iOS 5, unless I'm mistaken.
     
  3. xStep macrumors 68000

    Joined:
    Jan 28, 2003
    Location:
    Less lost in L.A.
    #3
    You are mistaken. Developers can target older versions of iOS.

    ----------

    Likely you'll be able to run Lion on that machine and Xcode 4.3.3, and maybe 4.4. I haven't checked the specs for 4.4 today. I wouldn't be surprised if the requirement for Xcode 4.5 will be Mountain Lion, but one can hope they will allow it to run on Lion as it does currently.

    Just because a new iOS version comes out does not mean everyone that can will upgrade. They are not forced to.
     
  4. Kashsystems macrumors 6502

    Joined:
    Jul 23, 2012
    #4
    right now xcode 4.5 dp requires either lion or ml, so I assume when the final product is released, it will be the same.
     
  5. tranceFusion thread starter macrumors member

    Joined:
    Aug 4, 2010
    #5
    hmmm.. I saw this in the FAQ:

    "The SDK for iOS 5.0 is only officially supported on an Intel Mac running Snow Leopard/10.6.x and later. The SDK and Xcode development tools for iOS 5.1 and later are only officially supported on a 64-bit Intel Mac running Lion/10.7.x."

    I figured then that they would follow history and that the SDK for iOS 6.0 would only be supported on Mountain Lion?

    Thanks for all the input everyone! I'll go ahead and purchase Lion and keep my fingers crossed.
     
  6. Duncan C macrumors 6502a

    Duncan C

    Joined:
    Jan 21, 2008
    Location:
    Northern Virginia
    #6
    Hard to say. Apple does tend to drop old OS versions for new releases of their development tools. Currently, iOS 6 requires Xcode 4.5, and Xcode 4.5 runs on 10.7 or 10.8. I would expect Xcode 4.5 to be released for both 10.7 and 10.8, since that's what it does now.

    Now that Mac OS 10.8 has released, the next release of Xcode may well require it.
     

Share This Page