ios7 Mail Fail

Discussion in 'iOS 7' started by webitorgal, Sep 18, 2013.

  1. webitorgal macrumors regular

    webitorgal

    Joined:
    Mar 9, 2011
    #1
    All my non-Gmail emails have been read, yet the icon still shows that I have over 1K emails! Does anyone know how to clear this?
     
  2. Stalyn macrumors regular

    Joined:
    Jul 7, 2012
  3. Steve121178 macrumors 68040

    Steve121178

    Joined:
    Apr 13, 2010
    Location:
    Bedfordshire, UK
    #3
    +1

    :)
     
  4. matttye macrumors 601

    Joined:
    Mar 25, 2009
    Location:
    Lincoln, England
  5. webitorgal thread starter macrumors regular

    webitorgal

    Joined:
    Mar 9, 2011
    #5
    Tried that. Didn't work.
     
  6. matttye macrumors 601

    Joined:
    Mar 25, 2009
    Location:
    Lincoln, England
    #6
    You made a point of saying your 'non-Gmail emails' have been read, so could it be your Gmail emails that are showing as unread? If so, you'd need to go into that mailbox rather than your non-Gmail one and mark all of those read.

    You should also try hard resetting the phone (hold home+power for 10 seconds).
     
  7. webitorgal thread starter macrumors regular

    webitorgal

    Joined:
    Mar 9, 2011
    #7
    Sorry, not my non-Gmail emails...I meant that my Gmail emails ARE clear, while the others ARE NOT. Oops!

    C
     
  8. matttye macrumors 601

    Joined:
    Mar 25, 2009
    Location:
    Lincoln, England
    #8
    So could it be your non-Gmail emails that are showing up as unread on the icon?
     
  9. webitorgal thread starter macrumors regular

    webitorgal

    Joined:
    Mar 9, 2011
    #9
    The mail icon shows that I have over 2K emails, but everything has been read. I'm trying to figure out how to clear that.
     
  10. hamiltonDSi macrumors 65816

    hamiltonDSi

    Joined:
    Jul 29, 2012
    Location:
    Romania
  11. matttye macrumors 601

    Joined:
    Mar 25, 2009
    Location:
    Lincoln, England
    #11
    I suspect you may need to remove and re-add those mail accounts.
     
  12. MBorati macrumors newbie

    Joined:
    Sep 18, 2013
    #12
    Having the same problem. 12K emails showing up, two accounts synchronized.
     
  13. webitorgal thread starter macrumors regular

    webitorgal

    Joined:
    Mar 9, 2011
    #13
    Tried that. Didn't work.
     
  14. mmoto macrumors member

    Joined:
    Mar 21, 2009
    #14
    Worked for me on my IMAP-based account

    Did not work on my account using POP protocol (Earthlink specifically).
    After re-adding the POP account, 3700 emails reappear.
     
  15. TheRealVertical, Sep 18, 2013
    Last edited: Sep 18, 2013

    TheRealVertical macrumors newbie

    Joined:
    Sep 8, 2010
    #15
    Yeah, I've deleted and re-added the accounts and it does not work.

    The only solution I've found was to log in to my Comcast account online and create a sub-folder in the inbox called "Archive" and move all of my email (over 9,000 emails) into that folder. Once I did that, it has cleared the problem up.

    But I'd hardly call that a 'solution'. Apple needs to implement a way to limit the number of days retrieved.
     
  16. webitorgal, Sep 18, 2013
    Last edited: Sep 18, 2013

    webitorgal thread starter macrumors regular

    webitorgal

    Joined:
    Mar 9, 2011
    #16
    I can't seem to mass unflag, either.

    ETA: Sorry....this was a Gmail issue....can fix it via Gmail. The other one still needs help...
     
  17. /dev/toaster macrumors 68020

    /dev/toaster

    Joined:
    Feb 23, 2006
    Location:
    San Francisco, CA
    #17
    I had had this problem in the past. Disable mail, refresh it ... then re-enable mail.
     
  18. webitorgal thread starter macrumors regular

    webitorgal

    Joined:
    Mar 9, 2011
    #18

    You mean disable the account? Tried that, didn't work.
     
  19. Hatchet macrumors regular

    Joined:
    Dec 9, 2007
    Location:
    Baton Rouge
    #19
    Same problem here. My issue is also with POP accounts. I had 2800 unread when i upgraded (which were all old emails) and I was able to get all but 3 to disappear. Only way I could figure it out is to keep scrolling and let the emails load up and the Edit > Mark > All Read

    However, these 3 phantom emails are driving me nuts. It even shows "3" for unread mail folder but nothing shows in that folder when i visit it.

    I've reset my phone, disabled my accounts, deleted and re-added. Nothing fixes it.
     

Share This Page