IOS9 Itunes

Discussion in 'iOS 9' started by rosenthalm1, Sep 28, 2015.

  1. rosenthalm1 macrumors newbie

    Joined:
    Oct 20, 2014
    #1
    Hi All,

    I have 3 devices. Ipod Touch newest model. Iphone 5S, and Ipad Mini first generation. Since the IOS9 upgrade, my ipod touch gives me a message when connected to itunes that it needs a newer version of Itunes to recognize this ipod. I have Snow Leopard and my itunes is as current as it can get without changing OS. My iphone seems to sync fine so I don't understand. My issue is whether I should take the plung and upgrade to Yosemite in order to get the new version of itunes. I love Snow Leopard and have been hesitant, but now devices are not going to work anymore with my imac so I need to do something. Any advice?
     
  2. ipooed macrumors 6502

    ipooed

    Joined:
    Sep 10, 2014
    #2
    I'm my opinion unless you have a SSD and at least 8GB RAM Yosemite will not do you any favours.
     

Share This Page