IOStorageFamily deleted in error

Discussion in 'OS X Mavericks (10.9)' started by T6Bird, Jun 21, 2014.

  1. T6Bird
    Expand Collapse
    macrumors newbie

    Joined:
    Jun 21, 2014
    #1
    Hi,

    I have accidentally deleted the file System/Library/Extensions/IOStorageFamily.kext by mistake. I know how stupid this was!

    Now my iMac (model 2008, running Mavericks) gets stuck on the grey startup screen and hangs forever after the Apple logo turns into a no entry sign whilst the wheel continues to turn forever, see the following link for image showing this screen:

    http://www.extensions.in.th/amitiae/06_2012_1/images/disk-1.jpg

    I have run Disk Utility from the install CD and repaired the disk permissions with no success.

    I have tried to run the rescue partition by using the Command + R key but this just displays my exsisting HD and does not show another option.

    I have tried to boot into single user start with no success. The screen eventually hangs and says it can not find IOStorageFamily.kext.

    I have tried to boot into safe mode with no success. It simply fails with the no entry sign as above.

    I have reset the PRAM but this did not make any difference.

    I have done a hardware test using the D key on startup but this returned no errors.

    Please can someone advise if there is any way to fix this problem and if the is then what is the best way to do it? I know that it is not a harddrive failing or anything else and is simply because I accidently deleted the IOStorageFamily.kext file. Surely there is a way to repair this?

    I appreciate any help or advice.

    Many thanks
     
  2. chrfr
    Expand Collapse
    macrumors 603

    Joined:
    Jul 11, 2009
    #2
    The easiest way is if you have another Mac running Mavericks which you can then use to copy the file from that to your iMac via Firewire target mode. If you don't have access to another computer, you'll need to start up from whatever system DVD you have for the iMac and then do a clean installation with that disc, until you are able to get to the App Store and reinstall Mavericks.
    It's probably unnecessary to add this but in the future, don't randomly delete system files.
     
  3. T6Bird
    Expand Collapse
    thread starter macrumors newbie

    Joined:
    Jun 21, 2014
    #3
    Thank you for your reply.

    I had not heard of the 'target disk mode' before and this could be as you say the easiest way to resolve the issue.

    Do you know if my iMac will show up as a disk on another machine if it can not even get past the initial grey screen?
     
  4. westrock2000
    Expand Collapse
    macrumors 6502a

    Joined:
    Oct 18, 2013
    #4
    It will not be booting from your iMac, it will be booting from the borrowed Mac, and will basically turn your iMac into a very expensive USB drive.
     
  5. h9826790
    Expand Collapse
    macrumors G3

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #5
    Or may be make a bootable Mavericks installer DVD / USB driver from others Mac to fix the problem (if you don't have the FireWire cable and don't want to buy one).
     
  6. T6Bird
    Expand Collapse
    thread starter macrumors newbie

    Joined:
    Jun 21, 2014
    #6
    Hi Westrock2000, thank you for explaing this option. I am going to try and use a bootable USB first as that is going to be easier than taking my Mac to a friends house and using theirs.

    I will try this and hopefully it works. I will let you know how it goes so that if there are other people who make the stupid mistake I did they wilol know how to fix it.

    I really do appreciate all the help and advice.
     
  7. T6Bird
    Expand Collapse
    thread starter macrumors newbie

    Joined:
    Jun 21, 2014
    #7
    I have managed to fix the problem by using the following method:

    http://support.apple.com/kb/PH13842

    After connecting to another Mac I simply copied the deleted file back into the correct directory from the host Mac.

    I then booted my Mac successfully and repaired the file permissions via Disk Utility.

    Thank you to everyone that helped as I really do appreciate it!
     

Share This Page