IP ISSUES...Please Help

Discussion in 'iMac' started by tech0925, Jun 17, 2011.

  1. tech0925 macrumors member

    tech0925

    Joined:
    Sep 4, 2009
    #1
    For some reason my Mac has been having problems keeping the right IP address every since around the time I either restored my IMac or around the time of a bad storm. I'm not sure which or even if that is relevant.

    I have replaced my cable modem not once but three times with still the same problem. I do not believe it is a connection problem at all. The online cable light never goes off and my charter cable telephone service remains online as well. Here are the issues:

    For some reason my IMac keeps reverting to a 169 IP address which is obviously not right. I do not have any routers, hubs, or wireless. Simply just the cable modem with the ethernet connection.

    When I have this problem and try to go on the internet it says I have no connection and the up and down sync lights on the cable modem remain off. Also, I can fix this by simply rebooting the modem and going through the networks diagnostics. However, this is extremely irritating as I am a stock market trader and do not need to loose my IP address during trading hours.

    What do you think is causing this and how can I fix it???????

    Thanks!!!!!!
     
  2. brucku macrumors regular

    Joined:
    Jun 19, 2003
    #2
    Have you tried adding a router? This would help because you could query each device and see which one loses it's ip when the problem happens.

    Alternately you could use a different computer and see If it has similar issues.

    Once you know it's the iMac you can take it for service if it's still under AppleCare
     
  3. chachawpi macrumors member

    Joined:
    Feb 7, 2009
    #3
    Add a router and then set a static IP on your Mac.
     

Share This Page