iP4 LED no longer works?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by EvanLugh, Oct 1, 2010.

  1. EvanLugh macrumors 68000

    EvanLugh

    Joined:
    Aug 29, 2007
    Location:
    Developer land
    #1
    Good morning. My iPhone 4 is running great however I've noticed over the past week the LED no longer works. I've tried apps (flashlight,etc), video/camera..all the usual attempts.
    If anyone has any ideas I'd appreciate the help, Thanks!
     
  2. Rajani Isa macrumors 65816

    Rajani Isa

    Joined:
    Jun 8, 2010
  3. EvanLugh thread starter macrumors 68000

    EvanLugh

    Joined:
    Aug 29, 2007
    Location:
    Developer land
    #3
    Yes, there's nothing to toggle. Thanks anyway tho.
     
  4. wvphysics macrumors regular

    Joined:
    Jul 7, 2010
    #4
    If you switch it to video mode and turn on flash and it does not work, that something isn't working right. You need to return it and get another.
    On a side note, LEDs themselves typically last through 10's of thousands of hours of use, it is usually the electronics that drive them that fail.
     
  5. EvanLugh thread starter macrumors 68000

    EvanLugh

    Joined:
    Aug 29, 2007
    Location:
    Developer land
    #5
    Thank you for that excellent response. I was hoping it was just software as I've had 0 problems with the phone, and is on 4.0.1 J/B'ed.

    Does anyone know if i phone support will they sort a door swap (you get iPhone send back with same courier.. Thankyou again and sorry for the delayed reply I'm not very well.
    Cheers :)

    Edit: and also the new device have 4.0.1, if I specifically ask
     
  6. wvphysics macrumors regular

    Joined:
    Jul 7, 2010

Share This Page