iPad 1 - 5.0.1 - Untethered Jailbreak Stable?

Discussion in 'iPad Hacks' started by jdr00ejr, Jan 5, 2012.

  1. jdr00ejr macrumors newbie

    Joined:
    Oct 26, 2011
    #1
    Hello iPad Hackers...

    I really want Mirroring as an option for my iPad 1. I have the HDMI Dongle and can't user it.

    Now that RedSn0w is allowing an untethered 5.0.1 jailbreak for the iPad 1 - who's using it? Is it stable? Are there any known issues/concerns? I'm definitely a newb when it comes to jailbreaking and don't want to mess anything up so want to hear from some that have done it first. Does iBooks work? I've read that was an issue with some jailbreaks. Anything else that doesn't working?

    Is DisplayOut the only option for Mirroring (or the best option)? Is there any free option?

    Any insight you guys can give a newb would be greatly appreciated.

    Thanks!
     
  2. Dav1 macrumors 6502

    Joined:
    Mar 14, 2011
    #2
    So far it seems at least as stable as iOS 5.0.1. iBooks does not work, but if you install iBooks, do not open it and then install iBooksfix2 iBooks will again work. Directv, and other apps that check for a jailbroken device will detect the jailbreak, and not work. xCon 14 works for me to permit Directv to work. There is a hack you can do to delete unused language packs that seems to freem up some memory and an iPad(1) needs all the memory it can get.

    Biggest issue for me is that Safari crashes at some sites that have a lot of images on web pages. This is an issue with iOS 5, not the jailbreak, itself. Hope that helps some...
     
  3. jdr00ejr thread starter macrumors newbie

    Joined:
    Oct 26, 2011
    #3
    Thanks for the info. Couple of quick questions based on the above:

    1) So I would need to uninstall iBooks after I jailbreak, reinstall, and then run the iBooksfix2? I assume that's in the Cydia Store?

    2) Don't have DirectTV and haven't read of any of my apps having jailbreak checks - but we'll see when I do it.

    3) Can you point me to info on deleting the language packs?

    Thanks again for the info. It does help!
     
  4. Dav1 macrumors 6502

    Joined:
    Mar 14, 2011
    #4
    If you upgrade to 5.0.1 and do NOT open iBooks before installing iBooksfix2 in theory you shouldn't need to uninstall it... Myself I always do a setup as new, when doing a major iOS upgrade, (going from 4.x to 5.x)...

    iBooksFix2 is not in the default sources, you'll need to add a source, that I probably shouldn't name here, but you can find easily enough by doing a Google search on iBooksFix2

    You'll need to download and install a mobile terminal which you can get from here, http://code.google.com/p/mobileterminal/downloads/detail?name=MobileTerminal_520-1_iphoneos-arm.deb and install with iFile.

    You would then open the mobile terminal and you need to be logged in as root. Type in 'su', followed by your root password (by default it is alpine). Then issue the following commands,

    Code:
    find / -type d \
    -name "*.lproj" -not -iname "en*.lproj" \
    -exec /bin/rm -vrf '{}' \;
    
    It will take some time for this command to complete, it will scan your disk, hunting for language packs and deleting them. You'll see lots of output, and it will pause a few times, depending on what all is installed, and needs to be removed. Go fix yourself something to eat while it runs. I didn't time it, but on my iPad(1) 64GB 3G I'd say it took a good half hour to maybe as much as an hour. I found these commands on the Internet, and copied and pasted them into mobile terminal.
     
  5. jdr00ejr thread starter macrumors newbie

    Joined:
    Oct 26, 2011
    #5
    I'm already on 5.0.1 and have been using iBooks. I've got loads of things on the iPad so am hoping I don't have to start from scratch when I do the jailbreak. So, I'll try the jailbreak, uninstall iBooks, reinstall, run the fix, then open. We'll see what happens. May have to wipe and start over.

    Thank you so much for your help - for a beginner this is awesome and much appreciated.
     
  6. Dav1 macrumors 6502

    Joined:
    Mar 14, 2011
    #6
    Just so we are clear, the key should be that you don't open iBooks after the jailbreak, before you install the fix. You can have been using iBooks at 5.0.1 as long as you are not yet jailbroken. After you jailbreak iBooks detects the jailbreak and then marks itself, and refuses to load, after that point. The uninstall should only be required if iBooks has detected that it is running on a jailbroken device.

    Good Luck...
    Always a good idea to backup first.
     
  7. Alveezy macrumors regular

    Joined:
    Jul 6, 2011
    Location:
    Hawaii
    #7
    just did it today and the YouTube app is just blank and white. any idea on how to fix this?
     
  8. scripto195 macrumors newbie

    Joined:
    Jan 11, 2012
    #8
    iBooks will not open on ios 5.0.1 jailbroken iPad 1

    I have ran the latest redsn0w 0.9.10b3. Tried logging in using ifunbox on Windows & copying the iBookFixGizmoWebs.deb. Tried manually removing using ifunbox and re-installing, not opening until running iBooksFix2 and get this error

    [​IMG]
     
  9. Dav1 macrumors 6502

    Joined:
    Mar 14, 2011
    #9
    So based on that image, your iBooks folder is messed up, and you can't delete it? First time I've heard of iBookFixGizmoWeb.deb don't know what it does. Do you have iFile?

    What I would do, if I didn't want to restore again, would be to try deleting in /var/mobile/Applications/ the old iBooks folder, (if you have iFile install, and set it to Applications Name on in preferences this folder will be the folder with a random name)

    Then in /var/stash/Applications you'll want to delete the iBooks folder. Then uninstall iBooksFix2. Then reboot your iPad. That should clear iBooks off the home screen and permit you to download it again. Once you've reinstalled iBooks install the iBooksFix2 again, and when prompted respring your iPad. After that completes reboot your iPad and then try opening it.

    Wish you luck. The hardest part without iFile is finding the correct folder name. As all application folders are given random names.
     
  10. scripto195 macrumors newbie

    Joined:
    Jan 11, 2012
    #10
    I do have iFile, and can navigate to var/mobile/Applications, but in there are all sorts of folders with random letters and numbers [​IMG]. I am using windows and also have iFunbox which allows me to get in here also. What I did earlier which I think may have messed me up is deleted in the Applications folder the iBooks folder. Then tried re-installing, and installing the IBooksFix2, but this is when I ran into this problem.
     
  11. Dav1 macrumors 6502

    Joined:
    Mar 14, 2011
    #11
    If you have purchased iFile, and perhaps even if you haven't if you tap on that little gear icon, you'll get iFile's preference screen, about half way down is an option to turn on Application names. Switch it on and you'll see the *real* (maybe human understandable names is a better choice than real) folder names. Be careful when using windows it can change permissions on you, and that will prevent programs from running...
     
  12. scripto195, Jan 11, 2012
    Last edited: Jan 11, 2012

    scripto195 macrumors newbie

    Joined:
    Jan 11, 2012
    #12
    That was very helpful, so now I see where iBooks is. Once in there I click on it and show the folders inside Documents, iBooks.app, Library, tmp, as well as two files. From this point what do I need to do in order to delete this folder?

    ---

    Ok, so figured that out. Clicked edit, slected iBooks, and clicked on the trash symbol, now going to try the rest.
     
  13. Dav1 macrumors 6502

    Joined:
    Mar 14, 2011
    #13
    You go back to the folder where you see the iBooks folder that was a random name before. You tap on edit, check it (that random name folder before). Then delete it. Note that will also delet all books and PDF files that you have in iBooks. So be sure you have backup copies of them. iTunes should allow you to redownload the one you bought from there. The more difficult ones will be the PDF files, and other books in your iBooks that you obtain else where.

    You could use funbox to copy the folders to your PC, just in case before you delete them. Hopefully everything important to you is in iTunes on your PC.
     
  14. scripto195 macrumors newbie

    Joined:
    Jan 11, 2012
    #14
    It worked! You are a genious thanks again!
     
  15. Dav1 macrumors 6502

    Joined:
    Mar 14, 2011
    #15
    LOL no I'm not a genius by a long shot. But thank you for the kind words, and thoughts.
     
  16. scripto195 macrumors newbie

    Joined:
    Jan 11, 2012
    #16
    Ok, now trying this fix on another iPad and it will not work. I follow all of the same steps and when trying to start iBooks after the final patch is applied it opens then just closes. On the first iPad I at least received a pop up that iBooks was not properly configured. Any additional suggestions?
     
  17. Dav1, Jan 14, 2012
    Last edited: Jan 14, 2012

    Dav1 macrumors 6502

    Joined:
    Mar 14, 2011
    #17
    The opening and just closing, in my experience suggest either bad permission setting, like I copied a folder from Windows using OpenSSH. Or a major issue.
    Don't think you copied files from windows, so....

    I'd start over, because it most likely would be quicker. Uninstall iBooks, by deleting their two folders, uninstall iBooksFix2, if you are prompted to respring respring, then once that completes power cycle your device. Download iBooks from iTunes by WiFi (not from iTunes on your computer) Re-install iBooksFix2, which should prompt you to re-spring, and then power cycle. Double check you are using the same source for iBooksFix2, that should work...

    You need to have jailbroken with beta3 (0.9.10b3) or rejailbroken with it, or have run Corona and have the newest version of it. Also if you can wait there are rumors of a new Corona patch that will fix this issue!
     
  18. scripto195 macrumors newbie

    Joined:
    Jan 11, 2012
    #18
    I have removed and retried this several times now. I did jb w 0.9.10b3. Not sure why it is not working, very frustrating . What is corona?
     
  19. Dav1 macrumors 6502

    Joined:
    Mar 14, 2011
    #19
    Corona is a Cydia tweak for people who jailbroke with a tether jailbreak and who want to be untether. It permits one to go untether with out re-running redsn0w or something like it. Sorry you are having so many issues.
     
  20. Dav1 macrumors 6502

    Joined:
    Mar 14, 2011
    #20
    Both corona 1.0-4 and redsn0w 0.9.10b4 are now out and fix issues that prevent one from running iBooks. I've installed corona 1.0-4 over my redsn0w 0.9.10b3 jailbroken iPad, after first deleting the iBooks folders, (with iFile) and rebooting. This has allow me to download and install iBooks directly from the apps store. No problems in opening iBooks for me.
     
  21. scoiattolo49 macrumors newbie

    Joined:
    Sep 17, 2009
    #21
    Thank you for the tip! :D

    I was trying to reinstall iBooks after the new Corona fix came out but I was stuck (having used the previous fix that moved the iBooks to the system applications). Dleting the iBook directory did the trick


    For clarity sake it should be noted that (if you have used the previous fix) the iBook directory is located in //Applications/
     
  22. scripto195 macrumors newbie

    Joined:
    Jan 11, 2012
    #22
    So my iPad 1 is still giving me issues. I tried removing the ibookfix2 respring, then rejailbreaking with latest Redsn0w didn't work app kept closing, as well as other apps. Then I tried removing with ifile, then re-installing ibooks, still same problem. What do I need to do to get this working again. And in what order, been at it for DAYS now :(
     
  23. Jade529 macrumors newbie

    Joined:
    Mar 18, 2011
    #23
    Hi, I was having the same problem. I used the fix from Tanz over on osxdaily at
    http://osxdaily.com/2012/01/16/redsn0w-0-9-10-b4-ibooks-fix-download/. It finally worked after I deleted ibooksfix2 from cydia and ibooks using ifile. Respring and install ibooks from apple store. I also used the latest corona update from cydia. Took a couple a couple of tries but worked. Good luck.
     
  24. scripto195 macrumors newbie

    Joined:
    Jan 11, 2012
    #24
    Just to follow up this post. I removed iBooksFix2, removed iBooks through iFile, Rebooted. Updated Corona to 1.8, installed iBooks from iStore and it appears to be working! Fingers crossed.
     

Share This Page