iPad iPad 1 jailbroken 4.3.1 - how update to 5.0.1?

Discussion in 'Jailbreaks and iOS Hacks' started by tsomekk, Apr 9, 2012.

  1. tsomekk macrumors newbie

    Joined:
    Apr 9, 2012
    #1
    Hi.

    I've spent all day on this..

    - I have an iPad1 (wifi+3G), jailbroken with 4.3.1
    - I want to update/upgrade to 5.0.1 (even if I lose all contents)
    - Was then planning on jailbreaking it again

    I DON'T want to update/upgrade to 5.1 - tethered is not an option for me.

    But on iTunes I keep getting error 3194. Have tried various ways, fixing hosts with TU or manually, but the error keeps appearing..


    Any tips on how to do this?
    I feel like I am missing out on something..


    Thanks in advance!
     
  2. f4780y macrumors 6502

    f4780y

    Joined:
    Jul 21, 2009
    Location:
    Troon, Scotland
    #2
    To install 5.0.1 you must have saved SHSH Blobs for your device and you need to use redsn0w or iFaith to create a custom pre-signed firmware using your blobs and then install it using pwned DFU mode.

    You can find the options in redsn0w under Extras > SHSH blobs.

    Once completed you can then use redsn0w to jailbreak it untethered :)
     
  3. tsomekk thread starter macrumors newbie

    Joined:
    Apr 9, 2012
    #3
    Hi f4780y, thanks for your fast reply!

    I have just backed up my SHSH blob on redn0w (I understand it's a .plist file in the same directory as redsn0w).

    Now if I have understood correctly, within redsn0w I have to stitch these blobs (4.3.1) together with the 5.0.1 ipsw?
    When I try to do that, I get a message saying "Those blobs don't appear to match the IPSW build"..

    What am I doing wrong here?


    Thanks again for all feedback
     
  4. tsomekk thread starter macrumors newbie

    Joined:
    Apr 9, 2012
    #4
    Now I have also installed iFaith.

    I also backed up my blobs throught iFaith.

    Now from within iFaith I am downloading the 4.3.1 IPSW,
    although I don't really understand why I have to download the 4.3.1 IPSW if I really want to install the 5.0.1 iOS?

    Bit confused here, I know..


    Any help is appreciated!
    peace
     
  5. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #5
    Just stick with redsn0w if you have your blobs/Apticket

    In redsn0w go to Extra's/SHSH blobs/Stitch

    Now select the IPSW 5.01 and redsn0w will make a custom IPSW with your blobs/APTicket stitched to the IPSW

    Put your iPad in DFU and in iTunes Shift-restore with the custom made IPSW
     
  6. Night Spring macrumors G5

    Night Spring

    Joined:
    Jul 17, 2008
    #6
    "just"? If you hadn't previously saved SHSH blobs, then all you just did was save the blob for 5.1. Blobs must be signed by Apple, and they only sign for the current firmware.
     
  7. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #7
    OP was JB he can get them from cydia
     
  8. Rizvi1 macrumors 6502a

    Joined:
    Mar 29, 2006
    Location:
    Laurel, MD (Baltimore, MD / Washington, DC area)
    #8
    I have Version 4.3.5 on my wifi-only iPad 1. but when it was on a version before (I think 4.3.3), it was Jailbroken. So I guess I have saved SHSH Blobs out there somewhere. Would that be helpful for upgrading my iPad's FW and JB-ing it as well? Or at least JB-ing the current FW version I have.

    Only issue is that I have a Mac. And I think redsn0w and iFaith both are for PC? I could use Parallels/Windows XP I suppose.
     

Share This Page