iPad 1 won't upgrade to 4.3

Discussion in 'iPad Tips, Help and Troubleshooting' started by julieknits, Mar 13, 2011.

  1. julieknits macrumors newbie

    Joined:
    Apr 22, 2010
    #1
    I'm having difficulty with trying to upgrade my husband's iPad 1 to 4.3. It's currently running 4.2.1. When I connect it to iTunes on our updated MacBook Pro, I see the text that a newer version of the operating softweare is available. I hit the Update button, it extracts the software, and attempts to verify it with Apple. That's the point when I get a message that the iPad could not be updated. "This device isn't eligible for the requested build."

    I attempted downloading the iPad1,1_4.3_8F190_Restore.ipsw file directly, and using the option key to load that file when attempting to update. Same result.

    Is this possibly related to the fact that I've used this iTunes with my new iPad 2? I did successfully upgrade our other iPad 1 (the one I'll sell) when 4.3 was released last Wednesday.

    It's not good if the iPad 2 is causing trouble updating the iPad 1. Any ideas?
     
  2. Bluemeanie1976 macrumors 6502a

    Bluemeanie1976

    Joined:
    Nov 1, 2009
    Location:
    Veliko Tarnovo, Bulgaria
  3. julieknits thread starter macrumors newbie

    Joined:
    Apr 22, 2010
    #3
    Yes -- everything (OS X, iTunes) has been updated. As I've already successfully updated one iPad, I don't see why this one would be different. The main difference is the use of an iPad 2 on this machine.
     
  4. Warbrain macrumors 603

    Warbrain

    Joined:
    Jun 28, 2004
    Location:
    Chicago, IL
    #4
    Have you tried a restore instead of an upgrade? Try doing it by going into restore mode (turn iPad off, plug in cable while holding down home button).
     
  5. julieknits thread starter macrumors newbie

    Joined:
    Apr 22, 2010
    #5
    I seem to have found a fix. I went to ~/Library/iTunes/iPad Software Updates and deleted the ipsw file that was there. Then I launched iTunes and tried and update again. This time it downloaded the file and succeeded in updating my iPad.

    Going by the Apple discussion forums, I'm not the only one this has happened to. I still don't know the root cause.
     

Share This Page