iPad 2 - Cannot be restored error (2)

Discussion in 'iPad Tips, Help and Troubleshooting' started by h4mza, Dec 23, 2013.

  1. h4mza macrumors 6502

    Joined:
    Jul 30, 2010
    #1
    iPad 2 stuck on recovery mode, tried to get out by holding home and power button but it doesn't work, it is stuck on Connect to iTunes screen. I tried restoring it but gets suck at like 60-70% Apple bar then iTunes gives me an error (2). I searched everywhere and cannot find anything about error (2). Can someone tell me what it means and how can I get my iPad to work please?
     
  2. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #2
  3. Johnick macrumors member

    Joined:
    Sep 11, 2013
    #3
    Have you tried DFU mode ?, aka a forced restore.
     
  4. h4mza thread starter macrumors 6502

    Joined:
    Jul 30, 2010
    #4
    Still not working. It's already of DFU mode and I reset the hosts file by removing the line which has anything to do with Apple. iTunes is already updated to latest version and all my Windows updates are upto date. Also disabled firewall, re enabled, allowed all software related to Apple to Private and Public networks. Don't know what else to do know, can someone help. I bought it like this from eBay so I don't know when was the last time it worked.
     
  5. The Mentiad macrumors newbie

    The Mentiad

    Joined:
    Dec 23, 2013
    #5
    This is happening to me too with my iPhone 4. I can't restore. It gets 90% through the updating firmware process and then seems to lag and then spit out error 2.

    ----------

    http://forums.macrumors.com/showthread.php?t=1654510&highlight=error+2

    This thread seems to address the same problem, although there was not too much indication of how they solved the problem.
     
  6. Applesolver macrumors newbie

    Joined:
    Apr 26, 2014
    #6
    error 2 fix https://www.youtube.com/watch?v=0Fl5cf9Rf-E&feature=youtu.be

    watch that

    :) https://www.youtube.com/watch?v=0Fl5cf9Rf-E&feature=youtu.be

    ----------

    This video worked for me
    https://www.youtube.com/watch?v=0Fl5cf9Rf-E&feature=youtu.be

    ----------

    Watch that tutorial fixed my iphone 4 https://www.youtube.com/watch?v=0Fl5cf9Rf-E&feature=youtu.be
     

Share This Page