iPad 2 can't sign in to app store

Discussion in 'iPad' started by ruvil, Aug 25, 2011.

  1. ruvil macrumors regular

    Dec 26, 2010
    So.. I'm trying to download some apps from app store on my iPad for the first time(i have had a iTunes account since earlier). It says "press continue to review you payment settings" when i do that, a screen pops up where I'm asked to enter my password - which i did. But it just does not want to log in, because the screen pops up again just like i would have typed it wrong.

    I can however sign in to the game centre - which in itself tells me that the password does work.

    Is there some special setting i should do while having it synchronised in iTunes?
  2. Tritons macrumors 6502

    Jul 12, 2011
    I had this problem because of my debat card. I had no money in it and I couldnt get App Store to work on my new iPad. When I transferred some money to my debat card everything worked fine.
  3. ruvil thread starter macrumors regular

    Dec 26, 2010
    Solved it now, that wasn't the case for me.

    iTunes however wanted me to retype the security number on my debit card, and after that it all was solved.
  4. Tritons macrumors 6502

    Jul 12, 2011
    well yeah it was same for me. and then they reserved 1 euro from my debate card.
  5. TheWheelMan macrumors 6502a


    Mar 15, 2011
    I was trying to update a Bible app on my iPad last night and I got the same error. It updated another app just fine, though, and it didn't give me any messages about problems with my payment options.

Share This Page