iPad 2 can't verify my location, even though Location Services is on

Discussion in 'iPad Tips, Help and Troubleshooting' started by chadxor, Mar 14, 2011.

  1. chadxor macrumors newbie

    Mar 14, 2011
    Picked up an iPad 2 Friday and it's been a real treat. I've enjoyed it immensely, more than I thought I would.

    While my Internet and app store are working fine -- I can even use iTeleport and most of my streaming apps* -- my iPad hasn't been able to verify my location in any app. I have in the settings Location Services turned on, and all of my apps that I'd like to verify my location are turned on as well in that section. It's a little baffling, and there's very little on this in Google, according to my search.

    Normally this wouldn't be a huge deal, but because MLB.TV requires it, I'm trying to find a solution. Does anyone have any suggestions? I'm going to probably swipe the device clean and start over. Hope that does this trick.

    *Though StreamToMe's audio stops with MP3's after playing for just 45 seconds. Is this because of low bandwith at home? It's confusing because I stream all of my content, even HD movies, flawlessly from my desktop to my HTPC in my living room. So that shouldn't be an issue I'd think.
  2. litfuel macrumors member

    Jun 23, 2010

    I had the same problem, I restarted it and it worked after that.
  3. chadxor thread starter macrumors newbie

    Mar 14, 2011
    Thanks litfuel! I tried that before and it didn't work, but this time, it did! What may have also helped was that I went into Maps and turned on location from there... Either way, this time it worked, so now I can watch some Spring Training baseball.

    Thanks again for the help! Sometimes the simplest option really is the best.
  4. sshams95 macrumors member

    Jul 12, 2009
    You just did a simple power off and power on? Or did you do a factory reset?
  5. vincenz macrumors 601


    Oct 20, 2008
    Better than having something wrong with the gps chip
  6. Wynspirit macrumors newbie

    Mar 19, 2011
    Cannot Determine Location

    Has anyone encountered this error on their iPad 2?

    Detailed solution would be appreciated


  7. Wynspirit macrumors newbie

    Mar 19, 2011

    The solution was quite simple.

    Power down the iPad using the power button at the top riight. Press and hold till you get the red power slide button. Give it thirty seconds in off position and then turn back on. It should work just fine once yu location serices under "General" is on.

  8. rlsanroman macrumors newbie

    Mar 20, 2011
    I'm having the same problem.. I also held both power and home button to reset it.. and after that it still wouldn't work.. and after that try I tried just normal shut down (holding power button and sliding power off) waiting half a minute.. turning it on.. I have a question Wynspirit.. You said that location services should be on in "General" but there is no location services on "General" its just under settings.. or did I misunderstood you?

    ps.. Im having this problem with the iPad 2
  9. mrndly macrumors newbie

    Mar 14, 2011
    Location services not working

    I have an ipad2 that is having this problem. I tried 2 recommendations that did not resolve the issue

    1. reset location services - this seems to correct the problem for most people from what I have read on apple support
    settings>general>reset>reset network settings

    2. restart ipad

    I have notiticed that in settings under wifi the choose a network keeping cycling even though it is connected to my network and browser and email works.
    Anyone else having this problem I have a wifi only ipad
  10. saving107 macrumors 603


    Oct 14, 2007
    San Jose, Ca
    I've used the Maps.app before on my iPad 2, but last night it didn't want to locate me, but a simple power down then power back on seemed to do the trick. Its works fine again.
  11. coryndiego macrumors regular


    Aug 6, 2008
    San Diego, Ca.
    WiFi no Gps?

    I'm reading the specks of iPad2 and debating which one to get. Am I reading correctly that the Wifi does not have a GPS chip but the 3G does?

Share This Page