iPad 2 connecting to wireless via G mode and not N mode

Discussion in 'iPad' started by halfmonkey, Oct 23, 2011.

  1. halfmonkey macrumors regular

    Joined:
    May 17, 2011
    #1
    I currently have a D-Link DIR 655 router and have the router set to transmit in N, G, and B mode. At first I only had my router transmit G and B but the signal wasn't reaching a far corner of my house so I went in and added N because it's supposed to be stronger, faster, and better performing. After adding N to the signal that the router transmits, I can't really say that I've seen any improvement in the signal for the iPad2.

    I just logged into my router settings and it shows that the iPad2 is connected via G mode and only receiving 36 mpbs while my other non-apple laptop is connected and receiving data at 54 mpbs. The wireless channel is only transmitting at 2.4 ghz but it is set to auto scan.

    Can anyone help me with this? I'm not sure why the iPad2 isn't connecting via N mode and since it is connecting through G mode, why is it connecting slower? Thanks.
     
  2. Dangerous Theory macrumors 68000

    Joined:
    Jul 28, 2011
    Location:
    UK
    #2
    Not sure, but try clicking forget network on the iPad, then reconnect.
     
  3. Meanee macrumors 6502a

    Joined:
    Mar 8, 2011
    #3
    A decent number of folks do not know that you must secure your network with WPA2 for the N mode to work. A lot of routs are configured with WPA, WEP, which won't work with N. Confirm your security settings.
     
  4. halfmonkey thread starter macrumors regular

    Joined:
    May 17, 2011
    #4
    :eek: +1 to that. Thanks for the info. I'll try resetting my settings and see if that works. I already changed everything back to B/G this morning so I'll wait til tomorrow to make the changes in case my wife uses her laptop.

    I will say that the router should have forced me to make security setting changes when I selected N mode because it I have my security on WPA, then what's the point of being able to select N when it won't work.
     

Share This Page