iPad 2 drops Wi-Fi, touch freezes up, and sometimes acts possessed.

Discussion in 'iPad Tips, Help and Troubleshooting' started by ndillon, Apr 9, 2011.

  1. ndillon macrumors newbie

    Jun 23, 2010
    After flawless operation since getting my iPad 2 on launch day I am now having some issues.

    1. Wi-Fi will randomly drop out.
    2. This causes the touch recognition to be unresponsive. Home button, power, volume buttons all fine.
    3. Occasionally the iPad will then act like it is possessed and will randomly perform touch related operations.
    4. This requires a reset, turning Wi-Fi Off and back on to recognize the network.
    5. A few times the Wi-Fi has "Grayed Out" and requires a rest of network settings to restore it.
    6. Also will cause the time on the iPad to become out of sync.

    I have tried doing a restore with and without using a backup file. The wireless router apperas to be functioning fine and is used by a Laptop, two iPhones, and a DS with no issues at all. The iPad had no issues for weeks either.

    Funny thing is that is seems to be happening only in the evening time. My wife uses it during the day while I am at work and she has had no problems.

    What are my options here? If I can fix this that is the best thing, but if not I purchased it at Best Buy WITHOUT a protection plan. Do I need to return it to Best Buy or take it to an Apple Store (An hour and a half away)
  2. Tom G. macrumors 68010

    Tom G.

    Jun 16, 2009
    Champaign/Urbana Illinois
    Either store will replace it, but I would go to the Apple Store. I think you will have better luck there.

    Where ever you go remember to be polite it will open more doors for you. Even I you have to go above the head of the person who initially works with you do so politely.
  3. chotty macrumors newbie

    Aug 21, 2007
    How odd...

    The EXACT problems have suddenly started happening to my iPad2!
    *As an aside, this is my THIRD iPad2, replaced twice for the LCD "Light leaking" issue around the screen bezel...
    I remember reading similar problems with iOS 3.x and iPad1 - OS update fixed it so, we shall see

Share This Page