Ipad 2 Push Notifications Not Working

Discussion in 'iPad' started by jayt101, Nov 25, 2011.

  1. jayt101 macrumors newbie

    Joined:
    Nov 25, 2011
    #1
    Hello Everyone,

    I have posted this on several other forums with no luck so I'm hoping someone here can shed some light with the issue i'm having with my iPad 2

    It seems that my push notifications don't work with apps such as IM+, facebook and IMO. Skype seems to work perfectly but I prefer to use IMO for msn. The problem is I never receive any notifications until I open the app. I'm currently on iOS 5.01 and have a DLINK DIR -601 router.

    Here are the things that I've tried.
    1) Reset network settings
    2) Change DNS to 8.8.8.8 and 8.8.8.4 (these solutions worked for about 5 minutes)
    3) Restart iPad with new DNS setting
    4) Ensured that all notifications are on within settings menu and have the 'push' slider turned on
    5) Enable DMZ for Ipad 2 using Ipad's ip address. (this is a hit or miss)
    6) Port Forward ports 5223 based on apples site http://support.apple.com/kb/HT3576

    I've had a android galaxy tablet 10.1 and I have never had any issues with getting notifications with that.

    Is there a problem with my iPad? Should I return it? I'm suspecting it may be an issue with my iPad....or my router, lol. Please help! THANKS
     
  2. Defender2010 macrumors 68030

    Defender2010

    Joined:
    Jun 6, 2010
    Location:
    England
    #2
    I've had the same issues myself. Emails are now pushing fine, as they were not in iOS 5.0. I guess it's just a bug and Apple will fix it in the next update. Until then I am willing to live with it. It does only affect certain apps as you say.
     
  3. mrrish macrumors regular

    mrrish

    Joined:
    Feb 14, 2008
    #3
    In the past 3 years, I have had the same problem and each time it was different (I moved apartments a lot). But here are my impressions:

    You may want to contact your ISP or the manufacturer of your router. I highly doubt it is the iPad's WiFi selectively blocking all push notifications.

    Does your ISP provide a router or modem? Sometimes these may have their own settings. Use an ethernet cable and bypass your router and see if there are any pre-set DNS settings on your ISP's modem.

    Try other non-google DNS servers using Namebench

    Finally, some cheap-o routers also have caused this problem for me (I bought a trend-net router for $0 after rebate). I could never fix these and ended up throwing it away. Maybe you can ask a friend or family member if there is another router than you can borrow to try and see if that fixes the issue?
     

Share This Page