iPad 2 stuck updating to 9.2.1 from 7

Discussion in 'iPad Tips, Help and Troubleshooting' started by css1323, Mar 24, 2016.

  1. css1323 macrumors regular

    Joined:
    Jul 15, 2008
    #1
    I have an old iPad 2 that was still on version 7.X.X. Updating failed through iOS GUI so I hooked up to PC and downloaded the update from iTunes that way.

    The iPad will update with Apple logo and progress bar displayed, but the progress bar fails to move past the half-way mark oddly.

    -I've already tried manually downloading another 9.2.1 .ipsw file
    -- Tried restoring straight to 9.3, tried going back to 8.4.1 but I hear Apple doesn't sign those files anymore
    -I've rebooted our router & PC
    -I've tried restoring on another PC
    -Tried limera1n for grins
    -Tried ReiBoot

    No matter how many times I've let it sit for about 30 mins to an hr it fails to fully restore, even after trying different USB ports. Again, the progress bar just stops moving past the half-way mark.

    Anyone else experience something like this?
     
  2. css1323, Mar 26, 2016
    Last edited: Mar 26, 2016

    css1323 thread starter macrumors regular

    Joined:
    Jul 15, 2008
    #2

Share This Page