iPad 2 Won't Sync Over Wi-Fi

Discussion in 'iOS 5 and earlier' started by BulkHedd, Oct 27, 2011.

  1. BulkHedd macrumors 6502

    BulkHedd

    Joined:
    Nov 13, 2006
    #1
    I just got an iPad 2 yesterday (my very first iPad) and upgraded it to iOS 5.
    I connected it to my MacBook Pro to sync and checked the wi-fi sync box but when I unplug the cable the iPad disappears from my iTunes sources.
    When I go into the iPad settings I do have the option for wi-fi sync but when I click the "sync now" button it just says "Looking for MacBook Pro" and never finds it.
    Now, I also have an iPhone 4 and it is able to sync just fine over wi-fi to the same computer on the same wireless network. Also, the iPhone 4 automatically shows up under iTunes sources when I'm connected to my network.

    I'm running the latest versions of everything (Lion, iTunes 10.5, etc..)
    It's just weird that one device works fine and the other doesn't.

    I did try quitting and re-launching iTunes and that did not help.
     
  2. HazyCloud macrumors 68030

    HazyCloud

    Joined:
    Jun 30, 2010
    #2
    You need to make sure "open iTunes when this device is connected" is checked. It really fixed my issues. You may also need to connect the iPad via USB and select "sync this iPad over Wi-Fi".
     
  3. Mr.C macrumors 601

    Joined:
    Apr 3, 2011
    Location:
    London, UK.
    #3
    Once you've connected it once with the cable and checked the Wi-Fi sync box you have to close iTunes and then re-open it. When you do that the iPad should show up under devices and you should be able to enable Wi-Fi sync.
     
  4. BulkHedd thread starter macrumors 6502

    BulkHedd

    Joined:
    Nov 13, 2006
    #4
    I did that and it didn't work. Strangely enough, when I restarted iTunes my iPhone 4 did an automatic sync, even though it wasn't plugged in to power.
     
  5. Mr.C macrumors 601

    Joined:
    Apr 3, 2011
    Location:
    London, UK.
    #5
    Mines the other way around. My iPad 2 will connect automatically but iTunes doesn't recognise my iPhone 4 over Wi-Fi.
     
  6. GraphicsGeek macrumors 6502a

    Joined:
    Sep 19, 2008
    #6
    Also make sure you click Apply after checking the Sync over Wifi box.
     
  7. wmcy macrumors member

    Joined:
    Feb 12, 2009
    Location:
    Charlotte, NC
    #7
    Where is "Devices"

    Where is the "Devices" option in iTunes?
     
  8. GraphicsGeek macrumors 6502a

    Joined:
    Sep 19, 2008
    #8
    This isn't strange If the checkbox to sync when device is connected is checked. When iTunes first opens it looks for connected devices and if that option is checked, it'll start syncing as soon as it detects your idevice on the network.

    ----------

    Left column where your playlists are located. If your device isn't connected or on the network, Devices won't be there
     
  9. wmcy macrumors member

    Joined:
    Feb 12, 2009
    Location:
    Charlotte, NC
    #9
    Thank you GraphicGeek.
     
  10. BulkHedd thread starter macrumors 6502

    BulkHedd

    Joined:
    Nov 13, 2006
    #10
     
  11. GraphicsGeek macrumors 6502a

    Joined:
    Sep 19, 2008
    #11
     
  12. tonyr6 macrumors 65816

    tonyr6

    Joined:
    Oct 13, 2011
    Location:
    Brooklyn NY
    #12
    Don't disable the Bonjour service. Watch out for certain utilities programs that might want to disable it. Even if you rein-able it and start it up it will not sync with the Wifi until you restart your computer.
     
  13. BulkHedd thread starter macrumors 6502

    BulkHedd

    Joined:
    Nov 13, 2006
    #13
    Well, this morning, after a reboot of my MacBook (for another reason) the iPad suddenly shows up in iTunes and I can now sync wirelessly.
    I guess that's all I needed to do.
     
  14. wmcy macrumors member

    Joined:
    Feb 12, 2009
    Location:
    Charlotte, NC
    #14
    Help!

    Just to be clear, if I've properly set-up my iPhone and iPad in iCloud, I should be able to see them in iTunes under "Devices", correct?

    If so, I am doing something wrong. The left column in iTunes only has a "Device" category only when I connect my iPad or iPhone with a cable.

    Any advice on what I am doing wrong?

    Thanks for any help.
     
  15. BulkHedd thread starter macrumors 6502

    BulkHedd

    Joined:
    Nov 13, 2006
    #15
    When you have each device connected to the computer, you should see a check box under the summary called "Sync over Wi-Fi connection".
    Make sure that box is checked and it should work after that, though you may need to relaunch iTunes and/or reboot your machine as I did.
     
  16. wmcy macrumors member

    Joined:
    Feb 12, 2009
    Location:
    Charlotte, NC
    #16
    Thanks BulkHedd. That makes perfect sense. I appreciate the clarification.

    Wm.
     
  17. GraphicsGeek macrumors 6502a

    Joined:
    Sep 19, 2008
    #17
    iCloud has nothing to do with syncing your iDevices with the media on your computer.
     
  18. Mr.C macrumors 601

    Joined:
    Apr 3, 2011
    Location:
    London, UK.
    #18
    It has nothing to do with iCloud. I don't use iCloud right now but my iPad 2 does show up. My iPhone 4S doesn't. It did in the beginning when I first got it though.
     
  19. trenfro macrumors newbie

    Joined:
    Jan 1, 2012
    #19
    how do i get my iPad to show up under devices in iTunes? after i disconnect it-it dissapears. Please help!
     
  20. bdizzlefizzle macrumors newbie

    Joined:
    Sep 14, 2008
    #20
    One thing I've learned about iDevices - settings appear to be right, but the device doesn't seem to follow them. For instance, I have photos or songs that are set to be on the device, and I can sync it 10 times, and they still won't be there. So, I have the same issue with my iPad 2, and also had some music that wasn't coming over.

    I unchecked the Sync Over Wifi check mark, and also unchecked for it to sync music. I did a sync. Detached it, reattached it, and then checked both of those boxes. It's now syncing over WiFi and the music I wanted on it is actually on it.

    Hope that helps some folks.
     

Share This Page