iPad 2 Won't Update To iOS 5!

KidZgOtMac

macrumors regular
Original poster
Jul 20, 2010
164
0
Mayaguez, Puerto Rico
I keep getting the this device is not eligible for the requested build error pop up. How can I resolve this? My device is on 4.3.5 but I want to update and can't seem to be able to any way I try.
 

Thetonyk123

macrumors 68000
Aug 14, 2011
1,627
1
Earth
I keep getting the this device is not eligible for the requested build error pop up. How can I resolve this? My device is on 4.3.5 but I want to update and can't seem to be able to any way I try.
You need to update to iOS 5.0.1 because iOS 5.0 isn't being signed by apple anymore.
 

zhenya

macrumors 604
Jan 6, 2005
6,685
3,287
Make sure to do a full sync and backup before trying to update. For good measure, do another manual backup by right-clicking on the device icon in iTunes and choosing backup. Now try updating to iOS 5.
 

KidZgOtMac

macrumors regular
Original poster
Jul 20, 2010
164
0
Mayaguez, Puerto Rico
What program? I only had Red Snow and I deleted it right after trying to downgrade. iPad still doesn't want to upgrade to 5.0.1 it says it is not eligible.
 

itsmemuffins

macrumors 68040
Jun 23, 2010
3,131
1,208
What program? I only had Red Snow and I deleted it right after trying to downgrade. iPad still doesn't want to upgrade to 5.0.1 it says it is not eligible.
You know, the one that lets you down grade. That one that has the blobs or something. :D
 

KidZgOtMac

macrumors regular
Original poster
Jul 20, 2010
164
0
Mayaguez, Puerto Rico
SOLVED! I went and edited the Hosts file which had some weird lines that said Block Adobe because I had a cracked Photoshop so I deleted those and there was one line that didn't have a # before it so after I did those things I was able to restore and update.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.