iPad iPad 3 after iOS8 update says computer not authorized for purchases.

Discussion in 'iOS 8' started by themusicmanrk, Sep 21, 2014.

  1. themusicmanrk macrumors newbie

    Joined:
    Jan 6, 2013
    #1
    I just upgraded to iOS8 for my iPad 3 this morning and tried to sync it to iTunes. As the below shows, it's saying that my computer is no longer authorized for the purchases on my iPad and when I click on Authorize this computer in iTunes it says it's already authorized of course. Is anyone else having this problem after upgrading to iOS8?
     

    Attached Files:

  2. pmau macrumors 65816

    Joined:
    Nov 9, 2010
    #2
    De-authorize your computer and authorize it again.
    Log in to the iTunes Store, Click on "Account".

    There is a point called "Manage Devices".
    Remove your Mac. You don't loose anything.

    The only Problem you have is when you want to associate your Mac with a different Apple ID.

    Which brings me to the most important thing.
    Make sure you are really using the same Apple ID on your iPad and your Mac.
     
  3. themusicmanrk thread starter macrumors newbie

    Joined:
    Jan 6, 2013
    #3
    I did everything you said pmau and it still gives the same error.

    I made sure both my iMac and iPad had the same username and password. When I did this, the Manage Devices button disappeared from the account option in the iTunes store. I also had to redo the iTunes match as well with my computer for some reason. I'm still getting the same error message about my computer not being authorized for purchases after making sure of the username and password. Not sure what to do next other than restoring my iPad which I'd rather not do.
     

Share This Page