iPad 3 - Pages, Numbers, Keynote not working.

Discussion in 'iPad Tips, Help and Troubleshooting' started by filmbuff, Jan 17, 2015.

  1. filmbuff macrumors 6502a

    filmbuff

    Joined:
    Jan 5, 2011
    #1
    I'm running 8.1.2 and I have updated Pages, Numbers and Keynote recently. I noticed a few days ago that none of them are working. When I open any of the apps I get nothing but a blank gray page. Have tried exiting the apps and reopening them and restarting the iPad, that didn't help. Anyone else have this issue?

    I also recently switched to iCloud Drive but I'm pretty sure they were still working after that and the last update killed them.

    I just tried to delete Pages and reinstall it, but when the apps started wiggling the iPad completely froze and eventually shut off. After the restart, same thing. It seems that iOS 8 has basically killed this thing.
     

    Attached Files:

  2. DMatt macrumors newbie

    Joined:
    Jan 31, 2015
    #2
    Same problem here. Reinstalled Numbers, deleted files on my iPad to free up space. I am now restoring the iPad. To see if that helps!
     
  3. DMatt macrumors newbie

    Joined:
    Jan 31, 2015
    #3
    Seems to work after restore fromm backup on my iMac.
     

Share This Page