iPad iPad (3rd Gen.) isn't connecting to Wi-Fi quickly

Discussion in 'iPad' started by sultanoflondon, Jun 14, 2018.

  1. sultanoflondon macrumors 6502

    Joined:
    Dec 3, 2013
    #1
    Hi all,

    My iPad (3rd Gen.) seems to fail to quickly connect to the Wi-Fi network of our home. I'm unsure as to why this is happening, since the Wi-Fi connection throughout our home is fairly strong & all our other iOS devices seem to connect as per normal.

    Sometimes the iPad's Wi-Fi connection drops out too unexpectedly too, I'm unsure as to why this happens as well.

    If someone could shed some light on this, I'd be very grateful.

    Thank you!
     
  2. ericwn macrumors 68000

    Joined:
    Apr 24, 2016
    #2
    Have you tried to forget the network and then establish a new connection to see if it improves?
    Do you see similar behaviour of this device when trying to connect to different WiFi networks?
     
  3. sultanoflondon thread starter macrumors 6502

    Joined:
    Dec 3, 2013
    #3
    Tried this, didn't seem to work...

    & no, I haven't tried that actually. But all other iOS devices that I use connect just fine?...
     
  4. cobracnvt macrumors 6502

    cobracnvt

    Joined:
    Apr 6, 2017

Share This Page