iPad 4.2.1 JB - No Airplay after using MyWi 4

Discussion in 'iPad Hacks' started by adambigjohn, Dec 4, 2010.

  1. adambigjohn macrumors newbie

    Joined:
    Oct 31, 2007
    Location:
    London
    #1
    Hi,
    I'm getting an issue with MyWi 4 where once I've shared my iPad internet via Wifi (perhaps USB too but I can't be sure on that), I lose the ability to utilise Airplay from the iPad until I reboot it. Yeap, I'm connected to my WiFi network with Apple TV 2 on it, but something that MyWi has set with the connection or not cleaned up, is not letting Airplay be detected until I reboot the iPad. Currently my jailbreak is tethered so this is a real pain.
    So anyway, is anyone able to:
    - Tell me what I'm doing wrong? I'm semi-technical so I can handle the geek version :)
    - Tell me the command I need to run in terminal to reset my network connection similar to what takes place in a reboot? I basically need to avoid rebooting here.
    Thanks in advance for any help you can provide.
    Adam
    ps. I've emailed Intelliborn about this, but no word whatsoever from them yet.
     
  2. 3goldens, Dec 5, 2010
    Last edited: Dec 5, 2010

    3goldens macrumors 68000

    3goldens

    Joined:
    Feb 26, 2008
    #2
    Big problem here with mywi!

    I can confirm this.
    I do not have Apple TV but I was able to stream to my home theatre via airtunes, worked fine.

    When I tried what adambigjohn described, I initiated airplay in itunes to my home theatre system, it was playing perfectly.

    I then initiated MyWi, it asked for a reboot as I had not used is since jailbreaking, I rebooted, MyWi started up with no problems but when I went to use Airplay the option had disappeared.

    I tried rebooting to see if that would allow me to stream again and the option did not appear again. I uninstalled MyWi, rebooted and the option stil did not appear.

    It now appears that I once had the option to stream and it is now gone!

    EDIT:

    I went to the program Remote and found that home sharing had been disabled, I resigned in and presto, I had the airplay option back.

    Now I am reinstalling MyWi to see if this process happens again.

    It does the exact same thing. I had to uninstall MyWi to get airplay back.

    When I installed mywi again, it disabled the airplay.

    But as soon as I started it, it knocked it out.

    I went thru the uninstall and reinstall process yet again and found airplay to be working.

    It appears that the reboot and initialization process of MyWi disrupts something in the os eliminating Airplay.

    I will submit a report to MyWi as well.
     
  3. 3goldens macrumors 68000

    3goldens

    Joined:
    Feb 26, 2008
  4. xeqshunr macrumors member

    Joined:
    Feb 3, 2011
    #4
    same problem

    I was using airplay perfectly with my Airport Express. After I installed MyWi 4.60.9 on my Verizon iPhone 4 greenpois0n JB AND USED IT AS A HOTSPOT, airplay no longer works. I verified my network was still working properly because my MBPro is still able to stream to the Express.

    BUT, after I used MyWi, I rebooted using SBSettings and the airplay functionality started working again! So, if you use MyWi, just reboot (NOT RESPRING) and you should get the functionality back.

    My Theory: The MyWi App takes your 3g cellular signal in on the cellular antenna. MyWi then REVERSES your wifi radio to broadcast (instead of receive) a wifi signal. This antenna reversal is the SAME FUNCTION as the airplay feature. So the problem must be that when you stop using MyWi, it doesn't reenable the airplay control of the wifi radio. You have to reboot the device so the iTunes App (by default) becomes the primary agent for the broadcast functionality.



    SIDE NOTE___________________________
    Using the Apple Remote App, I am still able to control the music from my laptop and stream from the laptop even if I don't reboot my device, soooo, that is a PERFECT work around.

    But really, just reboot your device, thats like 30 seconds. Remember, REBOOT, NOT RESPRING.
     

Share This Page