iPad 64GB 3G - Rogers 3G Issues - Canada

Discussion in 'iPad' started by nodootabooteet, May 31, 2010.

  1. nodootabooteet macrumors newbie

    Joined:
    May 23, 2010
    #1
    Hello,

    I set up my iPad 3g and everything is great. My only issue is reception / connectivity over the 3G network. I am on the Rogers network just outside of Edmonton Alberta. If I go into Edmonton I can get good 3G receptio, otherwise I get Edge or NO connection via the 3G. The funny thing is my Blackberry bold (also on rogers network) will have FULL strength reception in the same 'dead spot' as the iPad. Anyone else have this issue?

    I called Rogers and it was a **** show. I got forwarded to 5 different people and ended up getting advice to call Apple. One lady sounded like she saw there was an issue with my account not registering properly on the network and sent me to a guy 'who will fix this issue'. The guy then tried to sell me 3.5 gb/month plan for 40$ or a 150mb/month plan for $15. I told him I had already been charged for plans that were cheaper and better then that.. WTF ROGERS. NOT HELPING!!!

    Apple seemed to help a little bit more but nobody knows if it the SIM card or the iPad creating the problems. I need to find someone with an ipad sim that I can try in my ipad / my sim in their ipad.

    So frustrating!

    :mad:

    Besides all of the 3g mess, I love my ipad.
     
  2. bowzer macrumors 6502

    bowzer

    Joined:
    Apr 25, 2005
    Location:
    Ottawa, Canada
    #2
    Im not sure if this is the same issure your having, but Im having activation problems with rogers and 3g... Basically it's saying my activation is in process, and has been since 8am.

    As one person explained from this website:

    "Contacted Rogers again this morning at 10, spoke with the guy who told me that rogers and apple have been working together to figure the problem out, and apparently they know what the issue is now. They're figuring out a fix, and should have one by tomorrow. I asked if we should expect a phone call to let us know, the guy said maybe maybe not, just check your account from time to time to see if the activation goes through.
    Basically, everyone should be at the stage where they've entered their account information, registered, and received an email from rogers with a receipt. You will also get notification saying everything went through. You should be at the point where when you click on "view account", a pop up opens and says "Activation in progress". From that point just keep clicking on account from time to time to see if this screen changes, once it shows your account information, you should be able to use it. No sense in backing up the ipad, or restoring factory settings. This is strictly a waiting game, a problem with rogers/apple's compatibility."
     
  3. nodootabooteet thread starter macrumors newbie

    Joined:
    May 23, 2010
    #3
    I can confirm that my registration did go through. I just have issues with it actually connection on the 3g network. If I go into Edmonton the signal is clear and strong, but outside of Edmonton it HARDLY recognizes 3g, even though other 3g devices work fine.

    Is there anyone in Sherwood Park having iPad 3g issues?

    Thanks for your reply
     
  4. steve31 macrumors 6502a

    steve31

    Joined:
    Jul 20, 2007
    Location:
    Edmonton Canada
    #4
    I am having the exact same problem.
     
  5. Mirra435 macrumors newbie

    Joined:
    Jun 9, 2010
    #5
    Ipad Account issues

    I am having the issue that the My Account button on the ipad never connects to Rogers. I continually receive a message that the "service is temporarily unavailable". My registration notification informs me that their was a Plan Update Failure, but the ipad is working and connects to the 3G network. Of course Rogers states that it is a problem with the ipad. Apple support went through everything with me and they state that it is a Rogers account set up issue. Sigh ... Has anyone else had this issue and if so, do you know a solution. I cannot update my account from my ipad.

    Loving my ipad though. Cannot wait until Virgin Mobile offers plans. I hate Rogers.

    Mirra
     
  6. darkmoor71 macrumors newbie

    Joined:
    Jun 13, 2010
    #6
    iPad 64GB 3G - Rogers 3G Issues - Canada

    I had the same problem (service temporarily unavailable etc.) and spent hours on the phone this week with Rogers and Apple. I even put a new sim card in. Rogers had registered my account though and had charged my credit card so something had gotten through (now I have two accounts so I have to cancel the first one and get a refund). I learned that many people were having the same problem but Rogers and Apple were working on it.

    Surprisingly, my iPad received a notice this afternoon saying the account was now active and I was then able to access the internet. I tried all kinds of apps and they all seem to work, beautifully. I am now a happy customer. I also like the "usage" feature so I know how much I have used of my allotted 5GB.

    Wait it out a little longer. Hopefully your iPad will be activated soon.
     
  7. Hydrocity macrumors 6502a

    Joined:
    May 14, 2010
    #7
    Anybody having any problems with 3G in Calgary? Im thinking about getting a 3G iPad, but not if it doesnt work well
     
  8. silverblack macrumors 68030

    silverblack

    Joined:
    Nov 27, 2007
    #8
    No 3G issue in Ontario including Toronto and London.
     
  9. Mirra435 macrumors newbie

    Joined:
    Jun 9, 2010
    #9
    Rogers problems

    Did you have to say something specific to the Rogers people on the phone to get help? How long did you have to wait? I have been waiting ten days now.

    I keep calling Rogers, but they just give me the run around transferring me endlessly and telling me that the only way to update my account is on the iPad so if the iPad is not working they cannot help me. I also asked to cancel my account and apparently this can only be done through the iPad? Is there something I can do to help myself? At this point I just want to get Rogers out of my life. i love the iPad and the fact I cannot use it (no Wifi) is making me terribly sad. Sigh ...

    Mirra

     
  10. iFaninVan macrumors newbie

    Joined:
    Jun 22, 2010
    #10
    Rogers 3g network snafu

    Tried to activate my iPad yesterday here in Vancouver. Was on the phone for maybe an hour with several Rogers folk, and one woman from Apple in the U.S.

    Inserted SIM card and registered then received email saying that my activation didn't go through (and was told to check my credit card details) The title of the email was " Plan update failure". Discovered via Rogers that I had to install Apple iPad update software.

    After lengthy tech support calls, still cannot connect to the 3g network.

    Did go to Blenz coffee shop here in Vancouver and was able to use Wi-fi.

    Called Rogers again and guy said it was an issue at "(their) end" and that they were working on it.

    Frustrating, especially after waiting so long to get an iPad.

    Wonder if they could refund me and I could try another network? When I ordered iPad online from Apple, Rogers was the only choice.

    :apple:
     
  11. iFaninVan macrumors newbie

    Joined:
    Jun 22, 2010
    #11
    Cancelled Rogers, now have Bell Mobility

    Went to Apple store today and spoke to a "Genius". It was determined that the Rogers SIM cards were non-functioning, so they GAVE me a Bell SIM card, and I finally activated my 3G iPad via telephone! Can't believe how caring and helpful the Apple staff are at the Vancouver store. :)

    Had to call Rogers to cancel, got bounced around and finally the third person I talked to cancelled my account. My credit card was never charged, I don't think the activation went through properly.

    So, the Rogers 3G network didn't work for me. I recommend Bell, and Telus has a dataplan too.

    :apple:
     
  12. TonJay macrumors newbie

    Joined:
    Jun 26, 2010
    #12
    Rogers iPad activation problem solved by Reset All Settings

    With Rogers SIM, I would see logo and 3G in upper left of iPad. Then I went thru 10 attempts to activate a 3G plan on Rogers. Everything would enter OK andI would get to the final accept page. It would then give me a "Congratulations!" but I would never get 3G activation or confirmation email. Tried several credit cards without luck. 1 hour on Rogers tech support and CR was going to escalate to "level 2" and expect a call in the next 24-48 hours. Whatever. As final attempt before going to Bell/Telus (which has solved problem for several on this thread), I went to 'General>settings>Reset All Settings' (does not erase media or data), and when the iPad rebooted - suddenly a message that the iPad plan had activated on Rogers!! I had tried network setting reset before without luck.

    That seemed pretty easy but was never suggested by Rogers.
    Hope this works for anyone else that is having problem.
     
  13. iFaninVan macrumors newbie

    Joined:
    Jun 22, 2010
    #13
    As final attempt before going to Bell/Telus (which has solved problem for several on this thread), I went to 'General>settings>Reset All Settings' (does not erase media or data), and when the iPad rebooted - suddenly a message that the iPad plan had activated on Rogers!! I had tried network setting reset before without luck.

    That seemed pretty easy but was never suggested by Rogers.
    Hope this works for anyone else that is having problem.[/QUOTE]



    That's interesting! I THINK I tried "reset all settings", but it didn't work for me. Thanks for posting, though! Congrats on solving the problem! ;)

    A friend and I are going to attend a free 1/2 hour iPad workshop at the Pacific Centre Apple store. They are incredibly helpful there.....
     
  14. NorthernApple macrumors newbie

    Joined:
    Jun 28, 2010
    #14
    Rogers Renewal

    My first month just expired and I found that the plan did not auto renew. Worse, it locked me out of the network. Since this is the first day for renewals there were bound to be some problems. Rogers unlocked my account, but I had to manually renew. What was really odd was that the message on screen said that I had used all my cellular data (I have a 5GB plan and had used less than half of that).

    Back up and running now. At least until July 28.
     
  15. razorme macrumors regular

    razorme

    Joined:
    Jul 16, 2002
    Location:
    Calgary, AB
    #15
    That happened to me today - no auto renewal. I was also having trouble accessing the cellular data account screen and the Rogers FIFA app kept hanging at the title screen. I tried the "Reset All" suggestion and it has fixed my issues, at least for now!
     
  16. Jean Desjardins macrumors newbie

    Joined:
    Jan 19, 2011
    #16
    iPad 4.2, Rogers, "View Account", "Service Unavailable"

    Didn't fix it for me, still getting "Service Unavailable". Seems to pretty well sum up the situation with Rogers in general.

    Will try a Bell SIM *this afternoon*.

    TY
     
  17. ArchXyrho macrumors member

    Joined:
    May 15, 2009
    Location:
    Canada
    #17
    I got Rogers also on my iPad with the $20 500MB Monthly plan and when things go south I will swap a Bell prepaid sim I have for the iPad in. I hate Rogers but I hate Bell even more but too bad I would never use Telus but hey what can we do? They are the only big dog provider here in Canada. If you would ask me to rate them I would give Rogers **** and Bell ** and Telus * (out of five *)
     

Share This Page