iPad activation issue iOS 7 Beta

Discussion in 'iPhone Tips, Help and Troubleshooting' started by notitatall, Sep 25, 2013.

  1. notitatall macrumors newbie

    Joined:
    Jul 27, 2013
    #1
    Hello everyone,

    So I have a valid and up to date developer account with Apple, so a while ago I started using the iOS 7 beta on my iPad mini.

    At the moment, the iPad is unusable. It keeps asking to be activated and then claiming that the activation server is down.

    Now I assume, based on what I've been able to research thus far, that the beta version I was running has expired. I cannot remember which beta I was on, but it had been a while since I ran an OTA (Beta 3? Maybe?). I don't care much about the data I had on the iPad so I don't mind having to restore it back to iOS 6 or what have you in order to go back and update to iOS 7 in the conventional way, but while this seems to have worked for most people; it is flat out failing for me.

    When I connect my iPad to iTunes it tells me that the software has expired and that it needs to download an update. It downloads that update but then comes up with an error when trying to backup the device saying that it cannot communicate with the device and to replug it in. When I try with a local ipsw of either iOS 6.1.3 or iOS 7 (final verison) in restore mode or DFU mode; itunes tells me that the device "isn't eligible for the requested build."

    All of this seems rather silly is there another way of going about a fix that I am missing?
     
  2. ABC5S Suspended

    ABC5S

    Joined:
    Sep 10, 2013
    Location:
    Florida
    #2

Share This Page