iPad apps shutting off spontaneously

Discussion in 'iPad Tips, Help and Troubleshooting' started by Kantosam, Sep 26, 2010.

  1. Kantosam macrumors member

    Jun 28, 2010
    Searched the forms and didn't see ts issue, but I have an iPad about 4 months old -- purchased from Apple. At least three different applications: USA Today, Olive Tree bible application and a bowling game all turn on when I tap them, but then shut down spontaneously after about 5 seconds. I have to rest the iPad to get them to stay stable but I don't think I shouldnhave to do that. Anyone else have this issue? Any advice?
  2. prot0type macrumors regular

    Jul 12, 2010
    Some apps tend to do that. With me when I use the Marvel app it'll just shut down or run without a hitch. If anything, I haven't come across any problems using USA Today.

    Do you have the most current update installed on your ipad?
  3. blackNBUK macrumors 6502a

    Feb 19, 2010
    Is "rest" a typo? Did you mean "reset"? Having to reset an iPad to get an application to work isn't unheard of. It shouldn't be necessary but Apple and third-party developers aren't perfect.

    Have you tried starting an App a second time immediately after it has failed to start up? Occasionally I've had big games fail to start but AFAICR they've always worked on the second go. My guess is that the first time round the Apps aren't waiting long enough for the OS to clear out the memory that they need but by the second time enough memory is available.
  4. PhazonUK macrumors 6502

    Jun 1, 2010
    I've had the YouTube app and the YouTube website crash on me before as well as a few apps. Doesn't happen frequently though.
  5. Don Kosak macrumors 6502a

    Don Kosak

    Mar 12, 2010
    Hilo, Hawaii
    That will sometimes happen if you run out of memory. Are you running any big game apps, or something that might use a lot of memory?
  6. Kantosam thread starter macrumors member

    Jun 28, 2010
    ooops, yes, "rest" = "reset." Have also tried opening other applications after a failed start (well, app starts, but then shuts off) and it's still "catch as catch an." One or two will also shut down after 5 seconds of loading; others start fine. Anyway thanks all, just wondering. Thinking of returning it for replacement...
  7. SVT Amateur macrumors 6502

    Dec 22, 2006
    Tyler, Texas
    Are you running the 4.2 beta? I know I have seen this much more with the 4.2 beta than previously with 3.2.2.

    Also, I've had many times where the USA Today app crashes unexpectedly. Someone before said it may be due to lack of memory and I will say that after I started using a memory management program on the iPad I was surprised at how quickly the 256 MB memory filled just from running a few programs. But I would also be surprised if Apple hasn't implemented some way to keep this from being an issue.

    If you aren't running the beta then this probably doesn't affect you since you can't run more than one application in the background at a time. I would try a brand new restore and then reinstall all your applications before I tried to take it back for a replacement.
  8. Jaro65 macrumors 68040


    Mar 27, 2009
    Seattle, WA
    I noticed the same thing, mostly with USA Today. But sometimes iAnnotate and Zinio can be finicky as well. Overall though, vast majority of apps are robust. We'll see if more RAM is going to address these issues....
  9. Wolfpup macrumors 68030

    Sep 7, 2006
    I have Docs to Go 4 crash frequently on my 256MB iPod with 4.1 installed.

    Make sure that you reboot your iPad BEFORE installing/updating any programs, as some stuff won't run well if you don't, for some reason.

    Also weird is why rebooting should matter in terms of RAM use, since 3.x doesn't let you multitask anyway. Even 4.x multitasking is mostly fake...so I don't get that :-/
  10. bowlerman625 macrumors 68020


    Jun 17, 2009
    Chicago, IL area
    Is deleting the apps in question and reinstalling them an option?
  11. Wolfpup macrumors 68030

    Sep 7, 2006
    Yeah! Absolutely. I had to do that with something on my iPod to get it to work. I deleted it from the iOS device itself, then rebooted, then synced it and I think in iTunes had to turn syncing back on for that particular program.

    Might not fix it, but it might (I found out about it from some developers who recommended that before installing any iOS programs).

Share This Page