iPad apps will NOT update!

eroxx

macrumors 6502a
Original poster
Jul 27, 2010
801
1
I have tried everything - restarting, syncing with itunes, etc ... my iPad (new iPad) shows the apps "waiting" ... What can I do?!?!?!
 

HazyCloud

macrumors 68030
Jun 30, 2010
2,747
12
Wait?


Seriously, it seems to be happening to a lot of others. Just try waiting.
 

eroxx

macrumors 6502a
Original poster
Jul 27, 2010
801
1
it's been 2 days :) off and on, I haven't been in wireless the whole time, but still!
 

dmccloud

macrumors 6502a
Sep 7, 2009
991
14
Anchorage, AK
A couple of things going on here:

1. With a lot of people picking up new iPads and downloading directly to the devices, it's causing a massive hit on Apple's iTunes servers.

2. You can pause/resume any/all pending downloads by just tapping on the icon. One tap will pause the download, one will resume. Sometimes you can just pause all of the apps except one and then it will start downloading again. This seems to be because all the apps are trying to queue for download at once, overwhelming the connection to the iTunes store that authorizes the downloads.
 

WardC

macrumors 68030
Oct 17, 2007
2,729
207
Fort Worth, TX
Sometimes when you've got multiple downloads going on, it will create a "lag" -- also it could well be updating them, you only see "Waiting" on the ones that have not caught up in the download queue yet. I would recommend giving it some time, at least 30 minutes if you have a bunch of apps to update at once, and a slow connection.

Another thing could be a connection problem grabbing one of the apps off of Apple's servers which is stalling the process altogether.
 

GraphicsGeek

macrumors 6502a
Sep 19, 2008
533
0
It's no lag or some server backup. I had this happen for over a month a while ago. It eventually fixed itself but it was annoying.
 

Saberon

macrumors 6502a
Sep 16, 2008
982
0
This is a known issue, read the apple support forums for TONS of replies. Nothing you can do, Apple's end problem.
 

NATO

macrumors 68000
Feb 14, 2005
1,694
28
Northern Ireland
I've been pulling my hair out with this issue for the last few days and tried just about everything. What worked for me was to go to

Settings>General>Reset>Reset All Settings.

As soon as I did this the issue was fixed and I haven't experienced it since.