iPad iPad Keyboard - why no Full Stop (Period) or Comma?

Dino F

macrumors 68040
Original poster
Sep 16, 2010
3,011
997
Croydon, South London, UK
I have the original iPad Air 2 and it's on the most current iOS 13 firmware (whatever this happens to be - can't recall what the current version is but my device is on it!!).

I'm not sure if this is an issue or just the way my device is but on the keyboard (I am a U.K. user), on the far right of the keyboard (talking from memory as don't currently have my iPad at hand), i have the question [?] mark and exclamation [!] mark keys instead of the full stop [.] and comma [,] keys ?!

When I press the [?] and [!] keys, I can get the [.] and [,] in my sentences by using the shift key or the 123 key or the +#- key however, it means having to press these each time I need a full stop or comma?! Why don't the full stop and comma punctuation marks show on the keyboard instead of the question mark and exclamation marks....?!
 

Dino F

macrumors 68040
Original poster
Sep 16, 2010
3,011
997
Croydon, South London, UK
Ok, so I am on my iPad right now.

Next to the letter m, on the right, I see the exclamation mark [!] and next to that I see the question mark [?].

This does NOT change whether I press the left arrow shift key (on the left of the letter z), or the right arrow shift key (on the right of the question mark).

It also does NOT change when I press the bottom left .?123 key (on the left of the smiley emoji key) or the bigger .?123 key on the right of the space bar.

No other button combination presses change the exclamation mark or question mark keys neither.

For me to actually use the exclamation mark or question mark, I have to first tap either shift key and then press either the exclamation mark or question mark key. If I just tap either of these keys first, then I will get the comma [,] on the exclamation mark key and the full stop [.] on the question mark key.

This makes no sense as surely the keys should show the FIRST tap of the buttons - so the keyboard should show a comma and NOT an exclamation mark and similarly, show a full stop and NOT a question mark........?!
- - Post merged: - -

C59DA184-0A00-4B18-9CC5-1975245C6877.jpeg

This is what my keyboard looks like on my iPad.
 

mw360

macrumors 68000
Aug 15, 2010
1,640
1,522
Does it type in all caps? i ask because your shift key is active in that screenshot, and those keys are supposed to switch to ! and ? in that case. I guess you would have mentioned it though.
 
Last edited:
  • Like
Reactions: rui no onna

Dino F

macrumors 68040
Original poster
Sep 16, 2010
3,011
997
Croydon, South London, UK
Did you try the full power down & restart?
....no. Haven’t tried that - will do now but I’m 99% sure it won’t make a difference.
- - Post merged: - -

Does it type in all caps? i ask because your shift key is active in that screenshot, and those keys are supposed to switch to ! and ? in that case. I guess you would have mentioned it though.
It was only active as I took the screenshot. Whether the keyboard is locked in lower case or upper case, BOTH the exclamation mark and question mark keys are ALWAYS constantly visible on the keys - it doesn’t make any difference.
- - Post merged: - -

Just to also add - all my keyboard options (in Settings) are enabled other than ‘Key Flicks’ as I don’t like seeing the ‘key flicks’ above every letter!
 

sparksd

macrumors 68040
Jun 7, 2015
3,476
2,253
Seattle WA
  • Love
Reactions: Dino F

Dino F

macrumors 68040
Original poster
Sep 16, 2010
3,011
997
Croydon, South London, UK
I suggested the restart because of these -


Wow, that’s weird!!

So just rebooted and the comma and full stop now DO show under the exclamation mark and question mark keys:

01FFF5C4-A4CB-4011-863D-852FE81E1DA2.jpeg

These were NOT showing earlier?! Was this a glitch then?!
 

sparksd

macrumors 68040
Jun 7, 2015
3,476
2,253
Seattle WA
Good to see but these random glitches are irritating. When all else fails - reboot! Or maybe, reboot before trying anything else?
 
  • Like
Reactions: Dino F

rui no onna

macrumors G3
Oct 25, 2013
8,344
4,334
Wow, that’s weird!!

So just rebooted and the comma and full stop now DO show under the exclamation mark and question mark keys:

View attachment 894785
These were NOT showing earlier?! Was this a glitch then?!
I don’t think it was a glitch. I think it was just because you have the Shift key on. You’ve got the lowercase keyboard in this screenshot versus uppercase in your earlier screenshot.

Edit: Didn’t see your other post regarding same keys on both lower and uppercase. In that case, yep glitch. Probably memory related.
 
  • Like
Reactions: Dino F
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.