iPad/Netflix Problems

Discussion in 'iPad Apps' started by Justinm59, Jan 27, 2011.

  1. Justinm59 macrumors regular

    Dec 29, 2008
    I am using the Netflix app to try and watch a show instanlty and when I hit play it takes me to a page that says Instant Watching System Compatibility which just lists system requirements for a Mac or pc. Says nothing about an iPad, I've never had any problems before but this has been unsolvable for two days now. I haven't done a full reset/restore but i'm trying to avoid it. Any tips? Thanks!
  2. Justinm59 thread starter macrumors regular

    Dec 29, 2008
    I have tried deleting/redownloading the app a few times, logging in and out and restarting my iPad. I also have no problems playing Netflix on my xbox so the service is working.
  3. utl768 macrumors 6502

    Sep 8, 2009
  4. rmitchell248 macrumors 6502

    Mar 30, 2010
    Liebsthal, Germany
    i downloaded netflix but its blocked here....
  5. GfulDedFan macrumors 65816


    Oct 17, 2007
    Have you ever been able to watch instantly on your iPad?

    If you're using iOS4, doubletap the home button and delete the stored session of NetFlix in the bar at the bottom. Next open Netflix "fresh" and try to watch a show instantly.
  6. Justinm59 thread starter macrumors regular

    Dec 29, 2008
    Netflix had worked on my iPad but just stopped. I had tried force quitting and deleting none of that worked. I finally gave in and refreshed and that solved the problem.
  7. Srfergrl66 macrumors newbie

    Jan 29, 2011
    I'm having the same issue. Hoping that someone has the answer. I did erase app and redownloaded. Same problem about compatibility
    Issues. Don't know how to fix it! Help
  8. Srfergrl66 macrumors newbie

    Jan 29, 2011
    How did you do that?
  9. afireintonto macrumors 6502a


    Jul 22, 2008
    I think he means restored.
  10. adevia macrumors newbie

    Jan 30, 2011
    I have the same problem with my iPad. I watched a movie just fine last Monday, but when I tried it on Thursday, I got the described error. Called Netflix tech support, and they referred me to Apple. Spoke to apple tech support, and they told me that it was highly unlikely that it was the OS, but asked me if I wanted, I could restore my iPad to factory settings. I restored it, and just installed the Netflix app. It made no difference. I called Nexflix support yesterday, and after an hour on the phone, they just told me to check that I met the requirements. I tried to explain to the rep that it seemed that the app was attempting to function as if it was running in the browser (because a couple of times I tried to run the netflix app, I just got the same content I had in the browser's netflix tab), but he just kept insisting that I had to be running Safari v 3 or higher and a Macintosh OS.

    This is very frustrating.
  11. Cha macrumors regular

    May 1, 2010
    Just to make sure.... when you restored, did you set up the iPad as a new iPad or restored from a backup? Because restoring from a backup is probably copying the problem back on to the iPad.

    Did you install any programs from the last time the app worked?
  12. SFStateStudent macrumors 604


    Aug 28, 2007
    San Francisco California, USA
    Haven't had the described problems with Netflix, but a bit of buffering going on with George Carlin movie download....:(
  13. adevia macrumors newbie

    Jan 30, 2011
    I did set it as a new iPad. I did install one app from the last time Netflix worked, but after restoring iPad, only installed Netflix.
  14. Epic macrumors newbie

    Feb 2, 2011
    I had the same issue yesterday. It drove me bananas as it was a snow day and I was trapped in my house.

    I logged out, logged back in. I logged out, logged in as my sister's account. I closed all other applications. I deleted the app, re-installed the app. Same problems.

    I am not sure if this will work for you or not; but I closed all applications except netflix. Then I went to the netflix site on my browser (atomic) on the ipad. I searched for titles on the streaming. When I clicked 'play' the web browser launched the iPad netflix app and the movie loaded just like normal.

    After this happened once, I could no longer use the web browser to 'launch' videos in to the netflix app, but the netflix app works like it is supposed to (I can view lists and click play, movies load just like it should).

    I hope this works for my fellow mates struggling to be entertained. Please let me know if this works for you.
  15. adevia macrumors newbie

    Jan 30, 2011
    Thanks Epic. This pointed me in the right direction. I first tried what you suggested, but it didn't work. Then after messing around for a bit I FIXED it. If Epic's suggestion does not work for you, try the following. It did for me.

    1) Make sure that the date and time in your iPad are correct.
    2) Close all your running applications
    3) Launch Safari
    4) In the address bar, type the following : http://www.netflix.com/clearcookies This should take you back to the netflix login page.
    5) Close all active safari windows.
    6) double click on the Home button, and stop all apps listed.
    7) Power "Off" your iPad
    8) Wait a minute or so, and power it back on
    9) Launch Netflix app and Login.
    10) Launch Safari, go to Netflix home page and login.
    11) In the browser tap on a movie from your instant queue. This should open the Nexflix app and your movie should start.

    I hope this work for you.
  16. Epic macrumors newbie

    Feb 2, 2011
    well, I had it working again, but the problem came back and now I can't get it to work at all. I tried my original fix, I tried the steps adevia provided, and I am still not able to use netflix on the ipad.

    I called netflix, and they said they were aware of the problem. The rep directed me to apple, stating that Apple had a fix. Apple had no idea what was going on and just tried to hustle apple care for phone support. The apple tech recommended:
    1) deleting the app from my ipad and from my computer
    2) deauthorizing my computer, then reauthorizing it
    3) redownload the app to my computer
    4) sync my applications

    This didn't work either.

    I'm not sure what is more disappointing: apple or netflix.
  17. msflo macrumors newbie

    Feb 5, 2011
    Same problem on 2 iPads

    We have 2 iPads, one for the kids, one for us. BOTH iPads had said problem at the same exact time near the end of January. This leads me to believe it is a Netflix problem and not an Apple issue.
    I called Netflix and had no luck in fixing it. They suggested I call Apple, since the Netflix support guy could pull it up on his iPad through my account. I did not call Apple because I truly think it is a Netflix problem.
    However, the instant play from the same account works on our iPods.
  18. msflo macrumors newbie

    Feb 5, 2011
  19. johnwagnerjr macrumors newbie

    Feb 9, 2011
    Try this before restoring iPad ...

    1) Connect iPad to iTunes (PC or Mac)
    2) Disconnect iPad from iTunes

    I actually had this problem tonight (Netflix working last night and not working tonight). I tried everything posted here and nothing worked. My last effort was to to restore my iPad. I had to cancel my restore because I'm at a hotel and using VPN to my work network and my computer could not connect to the Apple server. Anyway, I disconnect my iPad from my computer and tried Netflix again for the heck of it and it's now working again. The restore did not actually occur.

    I'm not sure if the act of simply connecting the iPad to iTunes corrected the issue or the attempt to restore did it. Unfortunately, I think the either the Netflix App or the iTunes got out of sync with something.
  20. SpankDungz macrumors newbie

    Feb 10, 2011
    I had this problem for 2 days now. I just corrected it by checking my date and time. Somehow my date was a full 24hrs ahead. I simply corrected it and went back to netflix and it worked. Hopefully this will help you all.

  21. SpankDungz macrumors newbie

    Feb 10, 2011
    Check your date and time to make sure it corresponds to your timezone. Somehow my settings had messed up. After correcting my date, which was a full day ahead, and went back to netflix it worked.
  22. anyjah macrumors newbie

    Jun 10, 2008
    One Possible Solution!

    +1 - This worked for me as well
  23. Kathi T macrumors newbie

    Mar 5, 2011
    still not streaminng

    I tried all this after restoring in settings and still not getting streaming. I can stream netflix video at home on my macbook, mac mini and partner's dell but not ipad... And can view streaming from netflix at work any more suggestions?


  24. hermanski macrumors newbie


    Mar 12, 2011
    Wheat Ridge, CO
    My problem is different: I can connect and start a movie on Netflix, but all I get is the audio, no video. Anyone have suggestions for this? I have tried other fixes suggested above with no success.
  25. hermanski macrumors newbie


    Mar 12, 2011
    Wheat Ridge, CO
    Realized this only happens when I have iPad in Jensen Rocker Docking Station, when I took it out, iPad video works fine with Netflix. Anyone know why this happens with the docking station?

Share This Page