iPad performance better on G than N band?

Discussion in 'iPad' started by simers, Jun 2, 2010.

  1. simers macrumors newbie

    May 26, 2010
    Bath, UK
    I have a Netgear Dual Band DGND 3300 (with different ssid's on each as recommended) and the iPad is ok (but not brilliant) on the G band but pretty useless on N.

    Interestingly my MacBook Pro shows N to be the stronger signal whilst the iPad shows the opposite.


    Anyone else noticed the same?
  2. parish macrumors 65816


    Apr 14, 2009
    Wilts., UK
    Hmm, now that is interesting. When I was using my BT Home Hub for Wi-Fi (11g) my iPhone could connect when I was in the back garden. Now I've got an AirPort Extreme (11n) which is in the same place as the HH and my iPhone can't connect from the garden, although if it connects in the house and I go out into the garden it seems to keep the connection. Same behaviour with my iPad (although I didn't have it when I was using my HH).
  3. InsiderApps macrumors member

    Mar 18, 2010
    Mine seems to be slightly quicker at loading through my N network rather than my G, however I haven't physically tested it with times, however, as this is just from my experience.
  4. Seamaster macrumors 65816


    Feb 24, 2003
    I have a BT Home Hub 2.0, and have always had better range and stability with G than N across all my devices (iMac, MacBook, 2 x iPhones, iPad and Windows notebook).
  5. Figbash Acrobat macrumors 6502a

    Figbash Acrobat

    Apr 15, 2009
    This is likely true under certain circumstances (see the several other threads supporting better signal using G-only). I'm wondering if it's also that the iPad may work better in the 2.4GHz modes. Again, I think it will always depends on your specific setup, surroundings, etc., but I've had more success with G and 2.4GHz N with both an Airport Extreme and Belkin router.

    I'm curious to hear what other users are experiencing when comparing the two. However, it's clear that Apple needs to address the N connectivity problems some of us have had. Hopefully this is one of the "other issues" they are referring to when they announced a future firmware update.

    Edit: I should also note that my girl's MacBook has much better speeds in N so we keep the Airport running separate N and G bands to connect to. If I'm close to the base station N speeds are pretty good, but just one room over I have to be on G to stay connected. Regardless, her MacBook's signal is better than the ipad in any mode. I guess that's expected (more antennas, blah blah).
  6. Stardotboy macrumors regular

    Jan 30, 2008
    Manchester, UK
    I also have a BT HomeHub 2.0 (piece of ****) and it took me a while to work out the cause of my regular dropped WiFi connections - it was set up on N band, and when switched to G all the problems disappear.

    Ultimately it would be nice to be with a provider that gave a decent router, but for now I'll settle with G - at least it's stable.
  7. Macpowered macrumors member


    Feb 4, 2009
  8. Harmush macrumors 6502a


    Sep 21, 2008
    I have a d link 11n router and it's working great. The router broadcasts every band on the same SSID and I have not noticed a problem. Steady connection fast.
  9. AdeFowler macrumors 68020


    Aug 27, 2004
    My iPad and my brand new MBP only ever connect to the G (2.4ghz) channel of my new dual band Time Capsule. Even if I force them on to the N channel they go back to G the next time they wake up. The range of the Time Capsule is abysmal on both channels.
  10. parish macrumors 65816


    Apr 14, 2009
    Wilts., UK
    So how do I find out how my devices are connected (g or n) and how can I force them to g?

    I've turned off 5GHz mode so my MBP is connecting n @ 2.4GHz (Option-click the Airport icon in the menu bar).

    My AEBS has the following modes...


    which doesn't make much sense to me, and the Help isn't much help either..

    Set the radio mode to 802.11n (802.11b/g compatible), 802.11n only (2.4GHz), 802.11n (802.11a compatible), or 802.11n only (5GHz), depending on your base station and the client computers that will join your network.
  11. fehhkk macrumors 6502a


    Jun 11, 2009
    Chicago, IL
    Just select the 802.11a / 802.11b/g mode .. that should force you to G-mode only at 54Mbps.

    Also, I haven't had any issues with my iPad and 802.11a/n modes.
  12. parish macrumors 65816


    Apr 14, 2009
    Wilts., UK
    I've tried that - but it connects in 'a' mode :eek:

Share This Page