iPad Pro 11" Screen Lag

lotzosushi

macrumors 6502
Original poster
Jan 10, 2007
394
321
Been using the iPad Pro 11" LTE model since launch, overall very impressed and loving it so far. However I've noticed the OS sometimes lags detecting swiping inputs, like trying to swipe up from the bottom to open the app switcher. Sometimes it either doesn't recognize my swipe after several tries or it stutters. Sometimes it will recognize my swipe input halfway through my action and randomly press something I didn't intend to.

The worst is in the YouTube app, half the time my swipe inputs don't work. Even scrolling the page is broken and the only temporary fix is to lock and unlock the iPad again. Tried restarting/reformatting and it didn't help.

Anyone else have this problem? Wanted to see if it was a known problem or just maybe a hardware defect on my device before taking it in for repair or exchange.
 

lotzosushi

macrumors 6502
Original poster
Jan 10, 2007
394
321
Do you have a screen protector on it?
Actually I do, I have a tempered glass protector on it but didn't think of it as an issue since I've used glass protectors on every previous generation iPad before with no problem, even the 10.5" was flawless. hmm...
 

TaikoHax

macrumors newbie
Nov 20, 2018
9
6
Birmingham, UK
Actually I do, I have a tempered glass protector on it but didn't think of it as an issue since I've used glass protectors on every previous generation iPad before with no problem, even the 10.5" was flawless. hmm...
Yeah, afraid it appears to be an issue with this generation (I THINK 11" only but I could be wrong) - can't genuinely tell if it's an 'all 11" do this, it just depends if it's noticeable to you" thing or whether there's a small quality variance and some of us are getting the slightly duff ones..

I also have a previous gen 10.5 and 12.9 and the difference in touch screen performance/immediacy is night and day.

No one's come up with a root cause (i.e. whether is it hardware or software) but there is 'some' improvement if you switch to a film screen protector rather than a glass one.

I almost kept mine on the basis that it had improved with film but figured I wasn't in so much of a hurry and would rather wait until a fix...whether hardware or software, is known and then re-buy with a bit of confidence.
 

Newtons Apple

Suspended
Mar 12, 2014
22,764
14,918
Jacksonville, Florida
Been using the iPad Pro 11" LTE model since launch, overall very impressed and loving it so far. However I've noticed the OS sometimes lags detecting swiping inputs, like trying to swipe up from the bottom to open the app switcher. Sometimes it either doesn't recognize my swipe after several tries or it stutters. Sometimes it will recognize my swipe input halfway through my action and randomly press something I didn't intend to.

The worst is in the YouTube app, half the time my swipe inputs don't work. Even scrolling the page is broken and the only temporary fix is to lock and unlock the iPad again. Tried restarting/reformatting and it didn't help.

Anyone else have this problem? Wanted to see if it was a known problem or just maybe a hardware defect on my device before taking it in for repair or exchange.

You need to read this: https://forums.macrumors.com/threads/caution-new-ipad-pro-11”-glass-screen-protector-issues.2153098/page-3#post-26773859