iPad Pro LTE speed slower, reception worse?

Discussion in 'iPad' started by jjk454ss, Jun 15, 2017.

  1. jjk454ss macrumors 601

    jjk454ss

    Joined:
    Jul 10, 2008
    #1
    i picked up a 10.5 Pro, from a Mini 4, and it seems like the speeds are much slower when using LTE. I get poor service, but with my Mini 4 it seemed to be quite a bit faster even with a poor connection. Is this something others have noticed? I noticed they got rid of the ugly white area over the antenna, but was that at a loss of reception?
     
  2. jacklivehere macrumors member

    Joined:
    Oct 9, 2014
    #2

    I have same experience after switching from air 2.

    I also noticed these new iPad pros doent support new LTE bands such as band 66 or band 71 which is supported by Qualcomm x16 modem.

    Not sure what apple is upto
     
  3. jjk454ss thread starter macrumors 601

    jjk454ss

    Joined:
    Jul 10, 2008
    #3

    Yeah, kind of sucks;(
     
  4. aypues macrumors regular

    Joined:
    Feb 25, 2012
    Location:
    San Diego
    #4
    Arent those exclusive to T Mobile? I am reading they won't be deployed til later this year at the earliest.
    If not using T Mobile you shouldn't be affected, right?
     
  5. jacklivehere macrumors member

    Joined:
    Oct 9, 2014
    #5
    AT&T has more band 66 than T-mobile. So both are key for long term coverage
     
  6. aypues macrumors regular

    Joined:
    Feb 25, 2012
    Location:
    San Diego
    #6
    Interesting. That wouldn't explain slower speeds currently though since those new networks arent even active. I wonder what the problem is.
     
  7. Steve686 macrumors 68030

    Steve686

    Joined:
    Nov 13, 2007
    Location:
    US>FL>Miami/Dade>Sunny Isles Beach>Condo
    #7
    The AT&T is faster than my iPhone 7Plus in all tests so far on LTE. Also, wifi is blazing fast. Here are some tests I ran this morning.

    IMG_0008.jpg
     
  8. jjk454ss thread starter macrumors 601

    jjk454ss

    Joined:
    Jul 10, 2008
    #8
    So far I haven't found any fixes. I get maybe five or 6 Mb on my iPad, typically 30+ Mob on my iPhone, and 20+Mb on a hotspot. I hate to exchange the iPad and have the same issue, but does it seem like maybe it's worth trying a new one?
     
  9. Steve686 macrumors 68030

    Steve686

    Joined:
    Nov 13, 2007
    Location:
    US>FL>Miami/Dade>Sunny Isles Beach>Condo
    #9
    For one, what network and carrier are you using.
     
  10. jjk454ss thread starter macrumors 601

    jjk454ss

    Joined:
    Jul 10, 2008
  11. Steve686 macrumors 68030

    Steve686

    Joined:
    Nov 13, 2007
    Location:
    US>FL>Miami/Dade>Sunny Isles Beach>Condo
    #11
    What city and state?
     

Share This Page