iPad Pro Ipad Pro, Smart keyboard and MS Word app

Discussion in 'iPad' started by steinrr, Apr 12, 2018.

  1. steinrr macrumors newbie

    Joined:
    Jun 20, 2017
    #1
    There seems to be a lot of issues with the Word app on iPad Pro (using it with Smart keyboard), which really decreases the productivity.

    The bugs seems to be related to going to Home screen and back again into Word app.

    Here are some of the bugs:

    • Select functionality stops working

    Procedure to reproduce:

    1. Start a fresh Word app (make sure any previous instances have been shut down first)
    2. Observe that you can select text by using the keyboard + holding Shift key
    3. Push Home button
    4. Push Word app icon again
    5. Observe that selecting is no longer working and you have to shut down the Word app to make it work again. You can´t even select using touch on the screen.​


    • Command shortcuts stops working

    Procedure to reproduce:

    1-4. Repeat step 1-4 from above issue
    5. Observe that command shortcuts on keyboard (e.g. Copy-paste) does not work anymore. The app needs to be shut down again to make it work again.​


    • Storage starts failing

    After having used the app a while (and probably switching between apps, saving of documents fails. You then need to shut down the app to make it work again.​


    These are just some of the bugs which makes Word on iPad very difficult to use.

    Any others having the same issues?
     
  2. mk313 macrumors 6502a

    Joined:
    Feb 6, 2012
    #2
    --- Post Merged, Apr 12, 2018 ---
    I just tried select, cut, copy & paste using the steps you outlined above & it works perfectly for me. No issues at all.

    I’m on a 9.7” iPad Pro FWIW.
     
  3. steinrr thread starter macrumors newbie

    Joined:
    Jun 20, 2017
    #3
    Very, very strange. Do you select using the Smart keyboard (shift+arrows)? Is it the Apple Smart keyboard you are using?
     
  4. mk313 macrumors 6502a

    Joined:
    Feb 6, 2012
    #4
    Yes to both questions.
     
  5. steinrr thread starter macrumors newbie

    Joined:
    Jun 20, 2017
    #5
    Ok - thank you. Maybe I need to try to uninstall Word app and reinstall it.

    BTW - do you also have an Apple Pencil connected?
     
  6. mk313 macrumors 6502a

    Joined:
    Feb 6, 2012
    #6
    I have an Apple Pencil that I use occasionally on that iPad, so it is connected but I don’t use it often and it was not in the same building when I did my test.
     
  7. steinrr thread starter macrumors newbie

    Joined:
    Jun 20, 2017
    #7
    Thanks to mk313 I managed to solve the issue. I reinstalled the Word app, and then the issue was gone.

    After further investigation, I found out that the setting in "Settings - Word" called "Auto-format as type" breaks the keyboard selection (and many other things) if you turn it off. This is probably a bug in the app.

    So this solves a lot of issues in the Word app, but I still have one issue, which were the reason that made med adjust this settings some time ago.

    I normally write in Norwegian, and when I do, Word changes "i" to "I", which is totally wrong in Norwegian. I have not been able to find a way of disabling this.

    I have tried:

    * Disabling "Auto-format as you type" in "Settings - Word"
    * Disabling "Auto-Capitalisation", "Auto-correction", "Predictive English" in "Settings - General - Keyboards"
    * Disabling "Auto-Capitalisation", "Auto-correction" in "Settings - General - Keyboards - Hardware Keyboard"

    Nothing seems to work.

    Any ideas? I will also post a separate topic about this.
     

Share This Page