iPad Push Notifications For Email - What Gives?

boltjames

macrumors 601
Original poster
May 2, 2010
4,415
2,604
Long time lurker first time poster.

I just bought an iPad 3G and have not yet enabled AT&T as I'm at home on strong wi-fi. I have an iPhone and 5 iPod Touches along with an Apple TV, so I'm positive all my settings are correct.

Both my Yahoo and MobileMe email accounts don't push. When my iPad is sitting dormant and I get emails I hear my iPhone dinging all the time, no such luck with the iPad. Is there a reason? Push not possible over wi-fi?

TIA

BJ
 

msavwah

macrumors 6502
Apr 5, 2010
394
1
Oahu
I know for some reason yahoo accts don't even have the option for push. Check your settings.
 

boltjames

macrumors 601
Original poster
May 2, 2010
4,415
2,604
I know for some reason yahoo accts don't even have the option for push. Check your settings.
Yes, Yahoo push is an option in settings and it's turned 'on'. Push still doesn't work.

BJ
 

Merlosso

macrumors 6502
Apr 20, 2008
297
0
Mine works fine (non 3G model) with MobileMe email push notifications. Have you tried restarting the iPad? Have you had any issues with dropped wifi connections or the iPad forgetting your wifi password?
 

boltjames

macrumors 601
Original poster
May 2, 2010
4,415
2,604
Mine works fine (non 3G model) with MobileMe email push notifications. Have you tried restarting the iPad? Have you had any issues with dropped wifi connections or the iPad forgetting your wifi password?
Just did a restart so we'll see how that goes. No, no dropped wi-fi or forgotten password examples these lpast 5 years of iPod and iTouches.

BJ
 

xraydoc

macrumors demi-god
Oct 9, 2005
7,675
1,847
192.168.1.1
Not sure how to help. I've got Gmail set up as an Exchange account (push) and my wifi-only iPad receives it usually several seconds before my iPhone or Droid do over cellular. Even when the iPad is sleeping with the screen off, it always receives the push email.
 

boltjames

macrumors 601
Original poster
May 2, 2010
4,415
2,604
Tried adding and removing a few yahoo accts several times and there are only options for fetch and manual on them for me.

Weird
First off, you need to set up the email by tapping the Yahoo! icon in mail settings.

To see the Push submenu, go to Settings > Mail > Fetch New Data > Advanced and on there you will see each individual email account with its own settings.

Gmail = Fetch and Manual only.

Yahoo = Push, Fetch, and Manual.

My personal issue is that I've got the settings right but ain't gettin' the Push the way I do on my iPhone.

BJ
 

shady825

macrumors 68000
Oct 8, 2008
1,797
11
Area 51
Haven't had an email come to my iPad without manually checking..
I hear my phone ding but then the iPad never gets it unless i open mail..
Haven't done a restart since I had the iPad but I doubt that's a problem..
 

msavwah

macrumors 6502
Apr 5, 2010
394
1
Oahu
First off, you need to set up the email by tapping the Yahoo! icon in mail settings.

To see the Push submenu, go to Settings > Mail > Fetch New Data > Advanced and on there you will see each individual email account with its own settings.

Gmail = Fetch and Manual only.

Yahoo = Push, Fetch, and Manual.

My personal issue is that I've got the settings right but ain't gettin' the Push the way I do on my iPhone.

BJ
I'm saying I have done exactly that. I have rebooted the iPad as well. The yahoo accts only have fetch and manual available as settings


To make my issue even stranger, my MM and gmail(exchange) are pushing fine.
 

karmamule

macrumors 6502a
Jun 13, 2008
516
142
Waltham, MA
I have all my email accounts (including MobileMe and yahoo amongst others) all forwarding to gmail, and then i push from gmail via exchange and it works wonderfully for me.
 

boltjames

macrumors 601
Original poster
May 2, 2010
4,415
2,604
Make sure it's not sleeping.
Are you saying that if the iPad is asleep that Push email doesn't work? That if I've tapped the backlight button and started a meeting and I get 3 Yahoo emails while the iPad is sleeping that I won't hear the 'ding' and see I've got new mail?

BJ
 

bozzykid

macrumors 68020
Aug 11, 2009
2,177
238
Afaik fetch is set to manual on the 3G iPad as the default setting. So if you use a non push enabled email account it will not notify you by default.
 

boltjames

macrumors 601
Original poster
May 2, 2010
4,415
2,604
Afaik fetch is set to manual on the 3G iPad as the default setting. So if you use a non push enabled email account it will not notify you by default.
Yahoo mail is push enabled, works perfectly on my iPhone via ATT. No luck on iPad via wi-fi.

Help.

BJ
 

Gav2k

macrumors G3
Jul 24, 2009
9,217
1,606
Yahoo mail is push enabled, works perfectly on my iPhone via ATT. No luck on iPad via wi-fi.

Help.

BJ

You won't do when the ipad sleeps the wifi connection is disconnected hence why your having the issue. The iPhone has a constant data connection.

Example if I put my iPhone into airplane mode and turn wifi on I'll get my push emails via mobile me. If I allow my phone to sleep the connection times out shortly after and it's not till I wake it that I get my emails.
 

fjfjfjfj

macrumors 6502
Mar 20, 2009
300
96
New York, NY
You won't do when the ipad sleeps the wifi connection is disconnected hence why your having the issue. The iPhone has a constant data connection.

Example if I put my iPhone into airplane mode and turn wifi on I'll get my push emails via mobile me. If I allow my phone to sleep the connection times out shortly after and it's not till I wake it that I get my emails.
I don't know if I agree with that. I'm not an expert on the matter, but my wifi only iPad receives my gmail just fine when sleeping. It can be sitting on the table for hours idle and then I hear it "ding" and then I hear my iPhone "ding" when I have new mail. As a matter of fact, just yesterday my iPad had been unused all day and I was walking to the train with it in my briefcase and walked by a known wifi network and I heard it ding that I had new mail - no interaction on my part at all.

I'm not sure why some people are having these issues.
 

Hey Now

macrumors member
Apr 7, 2010
98
62
To see the Push submenu, go to Settings > Mail > Fetch New Data > Advanced and on there you will see each individual email account with its own settings.

Yahoo = Push, Fetch, and Manual.

BJ
I am not given a "push" option under my Yahoo settings on the iPad. It's present on my iPhone, but not on my iPad. Only fetch and manual. Anyone know anything about this?
 

boltjames

macrumors 601
Original poster
May 2, 2010
4,415
2,604
You won't do when the ipad sleeps the wifi connection is disconnected hence why your having the issue. The iPhone has a constant data connection.

If I allow my phone to sleep the connection times out shortly after and it's not till I wake it that I get my emails.
My iPad is getting push notifications from MobileMe while asleep. My iPad's been sleeping for 20 minutes and I just sent an email and my iPad 'dings' before my iPhone 'dings'. Push for MM works when iPad is asleep. Again, this is while I'm on wi-fi....I have ATT and cellular data shut off, never set up an account.

I don't know if I agree with that. I'm not an expert on the matter, but my wifi only iPad receives my gmail just fine when sleeping.

I'm not sure why some people are having these issues.
That's because you're using gmail which does not allow for Push natively in the iPad's settings (see below for additional information on how to set up in a different manner).

I am not given a "push" option under my Yahoo settings on the iPad. It's present on my iPhone, but not on my iPad. Only fetch and manual. Anyone know anything about this?
For me, to see the Push submenu, I go to Settings > Mail > Fetch New Data > Advanced and on there you will see each individual email account with its own settings. On the Yahoo account, there is an option for Push as well as Fetch.

BJ
 

boltjames

macrumors 601
Original poster
May 2, 2010
4,415
2,604
I stand corrected. You rock. Setting this up right now.

Question: Can I use this workaround for Yahoo mail to get it to push too? Haven't tested gmail, though. Hope it pushes.

EDIT:

My company does not have an Exchange Server, nor do I have one at home, so this 'fix' for gmail push is inaccurate.

BJ
 

Gav2k

macrumors G3
Jul 24, 2009
9,217
1,606
If you are getting MobileMe notifications then it has to be fetching.

No wifi on a wifi only model = no push. Think about it.
 

boltjames

macrumors 601
Original poster
May 2, 2010
4,415
2,604
If you are getting MobileMe notifications then it has to be fetching.

No wifi on a wifi only model = no push. Think about it.
So how do you explain ESPN sending me alerts every time the Yankees score or are scored upon?

My iPad spends 90% of its time asleep. MobileMe and ESPN push notifications are working. It's just Yahoo that's not.

What I'll do is turn off "fetch" completely and see if the MobileMe mail and ESPN push notifications get through.

BJ
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.