iPad restore problem

Discussion in 'iPad' started by yehoshua556, Aug 5, 2011.

  1. yehoshua556 macrumors newbie

    Joined:
    Aug 5, 2011
    #1
    Hi,
    I have a jailbroken iPad 2 (WiFi) running 4.3.3 I'm having some problem opening some of the apps it just goes blank for a sec and goes back to the home screen tried everything and can't get it to work (does anyone else have this problem or does anyone know how to fix it?) so i wan't to restore my iPad but I need to restore it to 4.3.3 so I can jailbreak it again I tried downloading the 4.3.3 firmware and pressing the SHIFT and restore and choosing it but i got an error and I can't restore.
    can someone please explain to me how I can restore my (working except for the app problem) iPad 2 that is running 4.3.3 to 4.3.3?
    Thanks!
     
  2. Saberon macrumors 6502a

    Joined:
    Sep 16, 2008
    #2
    Unless you saved SHSH blobs, you MUST downgrade to 4.3.5. Apple won't let you back to 4.3.3.
     
  3. AppleiPhones macrumors newbie

    Joined:
    Aug 5, 2011
    Location:
    Chicago
    #3
    Yes ^^^^^ he's right. Without the SHSH blobs you won't be able to downgrade. Apple stops signing the past firmwares when the new one comes out. Since 4.3.4 came out, apple stopped signing the 4.3.3 firmware. You will still be able to jailbreak 4.3.4 on your iPad if you desire but it's gonna have to be tethered.
     
  4. yehoshua556 thread starter macrumors newbie

    Joined:
    Aug 5, 2011
    #4
    As I wrote I am running 4.3.3 now which means I have the shsh blobs saved the only thong I want to do is restore my working iPad because of a problem I have to the same firmware 4.3.3!?
     
  5. yehoshua556 thread starter macrumors newbie

    Joined:
    Aug 5, 2011

Share This Page