iPad Safari Won't Load

Discussion in 'iPad Tips, Help and Troubleshooting' started by Hankcah, Jul 5, 2012.

  1. Hankcah macrumors regular

    Joined:
    Jul 8, 2010
    #1
    Currently have the iPad 2 and having issues with Safari/Chrome browsers.

    When I go to AA.com (searching for flights) I can load the first page, but when I try to navigate beyond the first page, nothing loads. Same goes for all websites.

    My internet access is fine since I can iMessage my friends and can send/rcve emails.

    Tried: Hard reset, turning on/off, clearing cookies and history, reset Network Settings.

    Are there any updates having to do with the safari browser?

    What else should I try? The nearest Apple store is over an hour away...

    Thanks in advance
     
  2. knoxtown macrumors 6502

    Joined:
    Nov 19, 2007
    Location:
    Everywhere
    #2
    This is happening with my Safari and icab browsers (started last night)... :confused:
     
  3. Hankcah thread starter macrumors regular

    Joined:
    Jul 8, 2010
    #3

    Hm. I have the latest update of 5.1.1. I don't see any known issues on the bugs list for apple, and can't really find any good ones at the moment. I may do a restore but I don't want to do that.
     
  4. knoxtown macrumors 6502

    Joined:
    Nov 19, 2007
    Location:
    Everywhere
    #4
    Yea, been busy so havn't had much time to look into it. Also, my screen is doing the flickering thing that someone posted in the main ipad forum page. Don't know what the hell is going on... :confused::apple:
     
  5. Alec Shaw macrumors newbie

    Joined:
    Jul 8, 2012
    #5
    Do you have any other web browsers installed? Then better try on those. Or try to double check your Internet connection.
     

Share This Page