All iPads iPad sending/receiving iMessages from a different address than iphone

Discussion in 'iPad' started by onirocdarb, Oct 21, 2013.

  1. onirocdarb macrumors regular

    Joined:
    Feb 5, 2013
    #1
    Both of my devices are signed in to the same Apple ID and both are running ios 7.x, but when I message people from my iPad they get it from my email not my phone number. When people reply back I the messages I sent from my ipad it does not go to my phone. Before I upgraded they were both from my phone number. If anyone could help me out with how to get them both to be from my phone that would be great
     
  2. NP9 macrumors newbie

    Joined:
    Sep 21, 2013
    #2
    I believe it should be Settings > FaceTime > Calling ID (don't know if it is exactly named like this since I have my iPad's main language set in Spanish).
    Select your phone number instead of your email address.

    I guess, from now on, your phone number will be shown for FaceTime calls and for iMessages from your iPad.

    Give it a try and tell us...
     
  3. Night Spring macrumors G5

    Night Spring

    Joined:
    Jul 17, 2008
    #3
    There's a separate setting for iMessage. I presume you can set FaceTime to send from a different address than iMessage, I've never tried.
     
  4. onirocdarb thread starter macrumors regular

    Joined:
    Feb 5, 2013
    #4
    Just tried going through setting to calling id.... It only shows my email, no option for a phone #
     
  5. Night Spring macrumors G5

    Night Spring

    Joined:
    Jul 17, 2008
    #5
    Ummmm, did you add your email to iMessage on your iPhone? I think once you do that, then your phone# shows up on your iPad. Kind of counterintuitive, I know.
     

Share This Page