iPad iPad stuck in "iPhone mode"

Discussion in 'Jailbreaks and iOS Hacks' started by evangw, Jul 7, 2011.

  1. evangw, Jul 7, 2011
    Last edited: Jul 8, 2011

    evangw macrumors regular

    Joined:
    Feb 9, 2008
    #1
    If this happens to you and all programs crash, then open up SBSettings via a finger swipe and respring. This will fix this issue!


    My iPad is suddenly stuck in a sort of 'iPhone mode' where it only allows 4 items in the dock, all programs open up in iPhone display, and it crashes if I try to open any program that is an iPad program, including settings.

    Any idea of a way out of this? I'm going to blame Retinapad for this, since it started happening as soon as I started using it with Grooveshark. I should be able to get into the iPad via SSH, just not here from work. Irritating.

    E: Needed to respring from SBSettings (phew, glad I had installed that). Now to figure out which program is the problem. Anyone know? On the other thread, someone blamed SBSettings, but if SBSettings is the culprit, I guess I can live with it.
     
  2. Shunnabunich macrumors regular

    Shunnabunich

    Joined:
    Oct 30, 2005
    Location:
    Alberta, Canada
    #2
    Oh hey, I just had this problem yesterday. I'm pretty sure it was Light Bright in my case. I started by making an extra backup using iTunes, then having it restore the iPad. It seemed to get almost all the way through, then get stuck just before the end of the progress bar and sit there indefinitely. What I did then was open up TinyUmbrella, which I had laying around from when I jailbroke my iPhone 3G, and it seemed to kick it the rest of the way over (who knows what it did, it just seemed to work!). I then had an iPad 2 running stock iOS 4.3.3, which I promptly jailbroke all over again with no further problems so far.
     
  3. evangw thread starter macrumors regular

    Joined:
    Feb 9, 2008
    #3
    If you have SBSettings installed, you can just use the "respring" button there and it fixes everything in like 2 seconds, which I think is much easier.

    We should probably keep a list of "destroys everything" applications. For me I'm pretty sure it was Grooveshark (crashed on first startup, tanked system immediately afterwards, and I haven't installed any themes or even very many other JB apps).
     
  4. jingsk macrumors newbie

    Joined:
    Jul 16, 2011
    #4
    I had that weird problem too. I had installed SBswitcher, before I noticed that this program is a problem. Just uninstall it (if you installed it). Hope this will help you.
     
  5. eagled macrumors newbie

    Joined:
    Jul 16, 2011
    #5
    Awesome help Thanks!

    I am /was a pretty good PC and Microsoft geek and gadget kinda guy.That was before I purchased my Ipad 2.Since then I am slowly but surely becoming a big apple fan .I had just started to get interested in having some fun hacking and tweaking my Ipad 2. The recent Jailbreak for the Ipad 2 made that real easy and I am hooked.Everything was going great and I was enjoying trying different tweaks,backgrounds, etc available on Cydia.Then today I thought it all come to a horrific end when I started my Ipad and had the issues everyone has already described in this thread(iphone mode,crashing when trying to open any app, etc).I could not figure out what was going on or how to fix it.After several hours of trying every reboot and shut down method possible- I had given up.I had my Ipad hooked up to my PC and Itunes . The restore and upgrade window was on my screen with cursor flashing on OK .With a right click of my mouse my Ipad was headed back to Apple jail for several months at best.Then I remembered your great site .I opened up another window and went into the Ipad forum.I see the the thread labeled "Ipad stuck in Iphone mode".After reading the posts I decided to follow the advice to hit respring from SB settings.My Ipad freezes for several seconds and then reboots to normal Ipad resolution.Great first sign but the real test is opening apps without crashing.I open several apps without a single crash!!!Pulled the usb cord from Ipad and shutdown Itunes along with the upgrade and restore window.Now I just need to figure out what caused the scare but with the help of this forum that should be easy.I realize this a rather dramatic and drawn out way to say Thank You to those who posted the fix for my Issue. I also realize losing your jailbreak is not a end of world event . Thinking you just ruined your new Ipad on the other hand -That is a rather unpleasant feeling...Thanks also to everyone that operates this great site.It really has some great advice on everything Apple related.I am a devoted fan of this site forever.I now can continue(until IOS 5 release)to learn more about the advantages of a jailbroken Apple device.Ec
     
  6. silicis macrumors newbie

    Joined:
    Jan 21, 2012
    #6
    probably related to mobile substrate dylib!

    This just happened to my iPad this morning. I recently found an tweak called 'flipover' for the iphone, which worked great on my 3GS. decided to install on the iPad (very bad idea, should have check compatibility first). anyway, after a reboot, the iPad lock screen look kind of weird & springboard is even weirder. since I didn't install openssh, ssh into the iPad isn't an option. what if I just remove the dylib that comes with flipover.

    fired up DiskAid & navigate to /Library/MobileSubstrate/DynamicLibraries & removed flipover.dylib and flipover.plist. After a reboot, the iPad was normal again.
     
  7. annikaann macrumors newbie

    Joined:
    Jul 5, 2012
    #7
    Whenever I restart my iPad, this happens.

    My situation is a bit different from the ones you described. Whenever I restart my iPad, it goes into this "iphone mode" that was described.
    When I tried to add a boot logo was the first time this occurred. I restarted my iPad to test out the logo. It didn't load and when I finally got to my lock screen, I was greeted by the iPhone keyboard to insert my passcode. I got to my home screen and just as described previously, everything was set up in this type of iPhone setup.
    I tried to open my settings and various other apps, but all of them crashed. I finally tried Cydia and that worked. I deleted the boot logo and to do that, I had to reset the SpringBoard on the iPad. Then, it was back to normal.
    I got rid of the application that came with the logo and a lot of stuff I had previously downloaded from Cydia.
    Now, even though I deleted everything that I thought would be the problem, my iPad still goes into iPhone mode whenever restarted.
    I don't have SBSettings, I couldn't figure out how to work it. x.x
    But I got an app called Easy Respring. Therefore, whenever I restart my iPad, I can just click that to easily Respring it, but I still don't know what's causing the problem :|
    Does anyone have any ideas?
     
  8. ProCon macrumors newbie

    Joined:
    Mar 1, 2005
    #8
    Intentionally put iPad in iPhone mode?

    Happy Thanksgiving. I was just with my grandmother, which led me to this thread, but I'm still stuck; is there a way to intentionally have an iPad function in iPhone mode?

    If anybody has an answer or method to do that it would make her life so much easier. If her iPad (1st generation) worked like a retina display iPod Touch everything would be big enough for her to see. Apple's accessibility panning options are too confusing for her.

    It sounds like I could try and manually modify some apps for her (NY Times & New Yorker) so they run in phone mode, but it would be easier to have it automatically do it for everything.

    Does anyone have any tips? Thanks a lot for the help.
     
  9. evangw thread starter macrumors regular

    Joined:
    Feb 9, 2008
    #9
    It results in almost every program crashing--it's essentially unusable in this mode. Maybe there's some way to activate it by choice without crashing, but you wouldn't want it happening as described in this thread.
     

Share This Page