iPad weird wifi issue

Discussion in 'iPad Tips, Help and Troubleshooting' started by danieltay, Aug 16, 2014.

  1. danieltay, Aug 16, 2014
    Last edited: Aug 16, 2014

    danieltay macrumors newbie

    Joined:
    Aug 16, 2014
    #1
    I've been connected to my house wifi using my iPad2(iOS7.1.2). The wifi connection has been excellent for a month with 9Mbps for download and upload speed.

    Just a few days ago, suddenly the download speed drop to 4Mbps, but the upload speed is good at 9Mbps.

    I tested my house wifi connection with android phone and windows 7 laptop, it is solid 9Mbps download and upload speed for both. I tested with iPhone 4s and 5s, both also getting 9Mbps download and upload speed.

    I use the same iPad2 to test on my friend wifi connection(different ISP), and the download and upload speed is good. Got a 9Mbps on download and upload speed.

    At first, I thought it is my iPad problem, ironically it works well with other wifi connections(but not my house wifi). It's not iOS as well since both iPhone 4s and 5s run the same version, 7.1.2.

    So what could be the reason for this weird wifi connection issue? I renew the wifi lease, I forget the network, I reset network settings, I reset all settings, but it is still the same, 4Mbps for download and 9Mbps upload speed.

    I want to blame on the router setting or the ISP, but it seems my house wifi connection is working well with iPhone. Is it possible that iPad required different router/firmware setting from iPhone(be reminded both on same iOS version)?

    My only guess is my iPad has some unknown issue with my house wifi connection(since it works well on other wifi connections). If this is the case, what could it be? What is the solution?

    Or do you guys have any other logical explanation?

    Please help, I am stranded in the middle of nowhere with no one able to offer any clue.

    Thanks in advanced.
     
  2. asriznet macrumors regular

    Joined:
    Dec 21, 2013
    Location:
    Singapore
    #2
    :D:D:D

    - Does your friend have the same internet plan & wireless router as yourself?
    - Have you done any troubleshooting on the network side like restarting the router?
    - Have you tried to disconnect all other clients from the network(wifi + LAN) and see if the issue happens too, bandwidth management might be the cause for this case.
    - If your router supports 5Ghz wifi, try using that, 5Ghz gives better bandwidth but not as good wireless coverage.
    - I would prolly attempt a restore on the iPad to test further.
     
  3. danieltay thread starter macrumors newbie

    Joined:
    Aug 16, 2014
    #3
    - Does your friend have the same internet plan & wireless router as yourself?
    tested on two different ISPs with different routers, but my iPad achieve maximum upload n download speed on both
    - Have you done any troubleshooting on the network side like restarting the router?
    Countless times of restarting, changing the router setting whichever way I can, but still the same
    - Have you tried to disconnect all other clients from the network(wifi + LAN) and see if the issue happens too, bandwidth management might be the cause for this case.
    don't quite get you on this, I did the speed test when my ipad is the only one connected to the router
    - If your router supports 5Ghz wifi, try using that, 5Ghz gives better bandwidth but not as good wireless coverage.
    - I would prolly attempt a restore on the iPad to test further.
     
  4. asriznet macrumors regular

    Joined:
    Dec 21, 2013
    Location:
    Singapore
    #4
    "tested on two different ISPs with different routers" = between your friend and yourself? or between 2 different friends(you not included)? :p if its the first case, then i'm confused are you still having the problem? :rolleyes:

    If it's the later, shouldn't the comparison be between YOUR network setup AND your friend's? because I thought we're having issues with your home wifi connection.
     
  5. danieltay thread starter macrumors newbie

    Joined:
    Aug 16, 2014
    #5
    honestly, this issue is a mystery:-
    if you wanna blame my home wifi connection... it works well with android phone, iphone 4s and 5s, windows 7 laptop... only my ipad has issue

    if you wanna blame my ipad... it works well with other isp... i tested my ipad with blackberry data mobile hotspot, it is working well as well

    so any clue?

    one more thing is i test the blackberry with my home wifi, the connection is 5Mbps for download and 7Mbps for upload speed... at least the upload and download is consistent

    this blackberry test add further mystery... could it be my home internet router/firmware setting?

    another thing is the slow download speed and good upload speed sounds like iOS issue... but if it's iOS issue, why the iPhone 4s and 5s with the same iOS version working well? as such, i exclude iOS as the culprit

    well guys, any clue based on this latest test?
     

Share This Page