iPad won't connect to wifi - "incorrect password" over and over

Discussion in 'iPad Tips, Help and Troubleshooting' started by Fugabutacus, Jan 26, 2017.

  1. Fugabutacus macrumors regular

    Joined:
    May 10, 2010
    #1
    Hi,

    I'm using an iPad Mini 1st gen running iOS 9.3.5 and I can connect to my router fine. However, I have a mains power wifi extender which is what I would be using the iPad on most of the time—if it would connect.

    Every time I correctly typed the password in, I would nonetheless get the "incorrect password" window.

    So I forgot the network and tried again. "Incorrect password."

    So I restarted the iPad. "Incorrect password."

    So I renamed the network and changed its password, and tried again with these new details. "Incorrect password."

    So I reset the iPad. "Incorrect password."

    So I did a full factory reset and set it up as a new iPad. "Incorrect password."

    Easy answer: the extender (BT HomeSpot) is at fault. Except, just to make things more complicated, my roommate's iPad Mini 1st gen, also running 9.3.5, connects with no problem and always has. Every single other device in the house—iPhones, Macs—also connect with no problems whatsoever.

    So seeing that there seems to be no problem with the wifi extender, and my iPad is for all intents and purposes an out-of-box model with no problems connecting to other networks—what the hell do I do now!?

    Help. Please. It's driving me crazy.
     
  2. ericwn macrumors 65816

    Joined:
    Apr 24, 2016
    #2
    Hm, tricky one. Can you exchange the extender device to test a second one? Best success!
     
  3. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #3
    Are you using a Smart Keyboard on your iPad?
    Maybe that is (incorrectly) capitalizing your first password character, and you don't realize it, as passwords are not displayed?
     
  4. Verntheworm macrumors newbie

    Joined:
    Nov 18, 2017
    #4
    I continue to get the incorrct password on my iPad, even though other devices connect fine. I did a work around by typing my password into “Notes” and copying and pasting the password into the wifi password space. I do not know why this works. I can see the characters are correct when i type them in, but it only connects with the pasted in version.. Odd!
     
  5. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #5
    Maybe your keyboard is set for a different language, or you are using an unusual keyboard, or auto-spell on the keyboard "corrects" the spelling of your password, etc.
     

Share This Page