IPad won't update to 4.2.1

Discussion in 'iPad' started by cokecan, Nov 23, 2010.

  1. cokecan macrumors newbie

    Nov 23, 2010

    I have an iPad which currently has 4.2.0GM (build: 8C134) I am not a developer but my brother is and he installed the GM on my iPad on his account.

    Now that 4.2.1 is released I have tried to update but iTunes just says that the current software is the most recent. I have tried to restore the iPad in the hope it goes back to a previous version but iTunes says "the resource *iPad name* cannot be located" even though the iPad shows in iTunes as a connected device.

    I'm guessing that my iPad is in someway linked to my brothers account and is for some reason stopping me upgrading?

    I have tried downloading the new file from apple direct and clicking shift update but the file is not extracting as an ipsw (I have windows 7 - sorry!)

    Any advice please?
  2. koopa35 macrumors 6502

    Aug 7, 2008
    Los Angeles, CA
  3. Redneck1089 macrumors 65816


    Jan 18, 2004
  4. Saberon macrumors 6502a

    Sep 16, 2008
    Wirelessly posted (Mozilla/5.0 (iPad; U; CPU OS 4_2_1 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8C148 Safari/6533.18.5)

    You must shift click restore to update to 4.2.1 from a beta or gm. Try downloading 4.2.1 using firefox instead of Internet explorer. Sometimes ie does weird things. You could also try Downloading with google chrome. I have windows 7 and updated from gm to 4.2.1 doing the shift restore method. I always get my iOS firmware from here

  5. Night Spring macrumors G5

    Night Spring

    Jul 17, 2008
    A common reason why ipsw files don't work is that the extension gets changed to zip when downloading. First thing you do when you download an ipsw file, check the extension, and if it's zip just change it to ipsw.
  6. cokecan thread starter macrumors newbie

    Nov 23, 2010
    I managed to get it going in the end by following the details in this thread: http://forums.macrumors.com/showthread.php?p=11474259#post11474259

    Basically a restore did the trick, although I did have to restore to a point which was before the GM install.

    For the other posters, I did eventually get the file unpacked but iTunes was asking for a password to extract when I attempted the manual upgrade.

Share This Page